Have you got v1.23 of sys/fs/devfs/devfs_vnops.c and are you running 
as non-root ?

> On Tue, May 15, 2001 at 01:34:27AM -0700, Peter Wemm wrote:
> > David Wolfskill wrote:
> > 
> > > Built -CURRENT & rebooted after mergemaster as usual, and some X
> > > applications (xbattbar; xlockmore; oclock) work OK, but no xterm.  At
> > > least, not from X (XF86-4.0.3).  I tried using Ctl-Alt-F2 to get to
> > > a non-X login, logged in , set DISPLAY to m147:0.0, issued "xterm &",
> > > and got an xterm OK.
> > 
> > Known problem.  phk changed the semantics of /dev/tty in the most recent
> > commits.  Traditional behavior for a process *without* a controlling tty
> > when it opens /dev/tty is to get ENXIO.
> I am confused now. I have just finished building and installing world and
> kernel from top-of-the-tree sources:
> FreeBSD fonix.hos.u-szeged.hu 5.0-CURRENT FreeBSD 5.0-CURRENT #42: Tue May
> 15 18
> :32:49 CEST 2001     [EMAIL PROTECTED]:/usr/src/sys/compile/FONIX
> i386
> and I am (for the first time ever) a proud owner of a devfs-powered FreeBSD
> system. So far things are looking A-OK. 
> Having read about all the trouble people were having with xterms, I grew a
> bit anxious and fired up X. It crashed because the config file contained
> /dev/mouse and that node no longer exists, but of course correcting it to
> /dev/sysmouse made things work. Then... I proceeded to open an xterm... and
> it opened! Just right-clicked the root window and chose xterm form the
> popup menu and it worked without any patch... although I am confident I do
> have the latest of phk-s commits and I am running on a new kernel... I am
> using XFree-3.3.6 and olvwm if that at all counts... of course I am happy
> to see no problems but why are others seeing them?
> -- 
> Regards:
> Szilveszter ADAM
> Szeged University
> Szeged Hungary

Brian <[EMAIL PROTECTED]>                        <brian@[uk.]FreeBSD.org>
      <http://www.Awfulhak.org>                   <brian@[uk.]OpenBSD.org>
Don't _EVER_ lose your sense of humour !

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to