On 19-Aug-01 Maxim Sobolev wrote:
> On Sat, 18 Aug 2001 21:10:40 -0500, Daniel M . Kurry wrote:
>> On Wed, Aug 15, 2001 at 07:01:46PM +0200, some SMTP stream spewed forth: 
>> > 
>> > One gets the first DMA buffer full, then the process hangs...
>> Due to the lack of replies, I'll go ahead.
>> I am seeing sound breakage also.
>> My card is a 
>> Creative Labs SoundBlaster Live!.
>> xmms will play a short (less than a second) spurt of audio and then stop
>> responding. mpg123 will not play (any audio to the speakers) at all.
>> I ran a buildworld today which apparently broke it.
>> That puts the breakage between today and sometime less than 2 months
>> ago.
>> (I really cannot be more specific.)
>> Suggestions gladly welcomed.
>> > -Søren
> The same is here (OPL3-SA driver on Toshiba Satellite Pro 445CDX notebook).
> I found that after reverting the following deltas (jhb's 10 August commit)
> sound starts working again:

That's a rather large commit.  Is this the ast() fixup?  Is the process that
has the sound device open hung?  Is it stuck in a wait channel?  If so, can you
do a ps and find the wait channel?  Is it chewing up large amounts of CPU time?
Has it exited with a signal?


John Baldwin <[EMAIL PROTECTED]> -- http://www.FreeBSD.org/~jhb/
PGP Key: http://www.baldwin.cx/~john/pgpkey.asc
"Power Users Use the Power to Serve!"  -  http://www.FreeBSD.org/

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to