If memory serves me right, Ruslan Ermilov wrote:
> On Thu, Sep 20, 2001 at 10:19:22PM -0700, Peter Wemm wrote:
> > Warner Losh wrote:
> > > In message <p05100307b7cfef6da22f@[]> Mark Peek writes:
> > > : Install a -current kernel on a 4.X or pre-kldxref (before 9/10/01) 
> > > : 5.X system. I sent a note to Warner mentioning he might want to put a 
> > > : comment about this in UPDATING.
> > > 
> > > I'm just unsure how to describe it...
> > 
> > It is actually non-fatal.  It should probably be added to the list
> > of tools to build for making the kernel. 
> > 
> This is not enough -- it should be made a cross-tool, much like
> the gensetdefs in -STABLE is.  The binary format produced is MD.
> If we don't, we should disable it (-DNO_XREF) for cross-builds.

Was there ever any resolution to this issue?  I just tripped over it
trying to update a 4-STABLE box to -CURRENT.  (The solution I used, 
which was to manually install kldxref and the version of libc.so that 
it was linked against, probably isn't general-purpose.)



Attachment: msg32413/pgp00000.pgp
Description: PGP signature

Reply via email to