On Sun, 30 Dec 2001, Sheldon Hearn wrote:

> On Sun, 30 Dec 2001 01:53:08 +0100, Michal Mertl wrote:
> > I have ntfs partition mounted ro on current. I can read from it without
> > problems. But I noticed I get corrupted data (the corrupted file has
> > right size but contains mostly zeros) when using ftpd to read them.
> >
> > I'm pretty sure the problem is thus in sendfile(2) and/or ntfs fs support.
> See also PR bin/31692, which reports simmilar problems using ftpd and
> smbfs.  See my request for feedback, which ought to help verify that
> it's sendfile(2) causing the problem.

I did use the "goto oldway;" and the problem went away. I tried to look at
/sys/kern/uipc_syscalls.c sendfile implementation but it is too complex
for me :-(. I tried ktrace on ftpd but only saw the call to sendfile(2).
If you give me some guidance I can try to look into problem deeper. I
don't have any experience in kernel debugging but would like to learn it.

> Ciao,
> Sheldon.

Michal Mertl

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to