Ah- this bit Marcel with FreeBSD-ia64 too. I hadn't gotten too that.

I haven't tried it yet in i386. Worked for in Alpha && Sparc64, but I guess it
didn't work for all alphas. I just reinstalled 5.0 and will be trying an i386
kernel shortly.

It would seem to me you can't have BUS_SPACE_MAXSIZE less than MAXPHYS- that
seems absurd to me.

What happened here is that in trying to make isp work for sparc64, I redid the
usage of bus_dma. Since the author never finished man pages or wrote up a
spec, the implementations (and architecture) is open to interpretation.


On Thu, 4 Apr 2002, Andrew Gallatin wrote:

> I just booted a recent current (or rather attempted to) and saw this
> when attempting to mount root from a qlogic card on my miata:
> bus_dmamap_load: Too many segs! buf_len = 0x2000
> spec_getpages:(da0a) I/O read failure: (error=22) bp
> 0xfffffe0004087ae8 vp 0xfffffe000ae90000
>                size: 98304, resid: 98304, a_count: 98304, valid: 0x0
>                nread: 0, reqpage: 7, pindex: 59, pcount: 12
> vm_fault: pager read error, pid 1 (init)
> <... more of same ...>
> The only way I could get the system to boot was to increase
> BUS_SPACE_MAXSIZE to 128K to match MAXPHYS.  I don't know why they
> don't match in the first place (they don't match on x86 either, so the
> driver will probably puke there too.)
> #define BUS_SPACE_MAXSIZE    (128 * 1024)
> Does anybody know why BUS_SPACE_MAXSIZE != MAXPHYS on some platforms?
> Thanks,
> Drew

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to