Alexander Langer wrote:
> Thus spake Terry Lambert ([EMAIL PROTECTED]):
> > > What's going on wrong here?
> > > GCC 2.9x can compile this, 3.1 cannot:
> > Delete and reinstall your header files.  They must match
> > the compiler you are using, and you must not have stale
> > header files from the previous compiler version.
> The -STABLE -> -CURRENT upgrade path is broken then.

Yes.  The same way it leaves the system version of perl installed,
instead of deleting it out from under you and forcing you to
install the package/port to get perl back.

> > Use at least GCC 3.2, if you feel compelled to use a buggy
> > non-maintenance release level GCC; alternately, wait for 3.3.
> I felt like using -CURRENT's 3.1, as it is expected.
> Well, I'll try to look if a new world fixes the problem, though I bet it
> won't.

If you have anything installed already which you don't rebuild
(e.g. C++ libraries), then you will not be able to link the old
and new code, since the C++ implementation details have changed
sufficiently that object files generated by different versions
of the compiler are no longer binary compatible.

Going to 3.2 or the 3.3 beta version will at least make an
effort toward you not having the problem again, in the future.

If you treat -current as a stand-along thing, and not something
that's supposed to work all the time, and for which upgrades
from source will work without problems, then you won't run into
things like this in the future.

-- Terry

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to