On Mon, 22 Mar 2010 15:42, deischen@ wrote:
[ Some CC's stripped ]

On Mon, 22 Mar 2010, M. Warner Losh wrote:

P.S.  I think that there's much traction to the idea of moving from
COMPAT_FREEBSDx to some other variable called, for example,
COMPAT_FREEBSD_BACK_TO=x, which will give compatibility for binaries
as old as FreeBSD x.0, and have all the other magic handled behind the
scenes.  This would render the inconsistency with COMPAT_FREEBSDx part
of the debate completely moot.

Doesn't matter.  We're still use to COMPAT_FREEBSDx since
it's been here so long.  So regardless if you rename them
to COMPAT_FREEBSD_BACK_TO=x, it is still potentially confusing.

COMPAT_ARCH32 and all other choices David mentions seem like
much better names - even if there wasn't any existing

My $0.02.

Ill say it again if I have to... COMPAT_ELF32 or possibly even ELF32_SUPPORT seems to me as a very likely possibility.

Maybe even:
SUPPORT_ELF32=          # Support for 32 Bit ELF Binaries

This would add its own name structure that is expandabe later-in-future when 128 Bit systems come out ;)




freebsd-current@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"

Reply via email to