Sendmail and I aren't getting along well. I got this FreeBSD
6.0-RELEASE-p7 box doing SMTP work for me. Everything is fine, but a few
domains give me headaches with "Deferred: Operation timed out with
<server here>" errors. One domain in particular I'm trying to get to
work is hospitaldeninos.cl

$ host hospitaldeninos.cl
hospitaldeninos.cl has address
mail is handled by 4 nt_sql_server2.hospitaldeninos.cl.
mail is handled by 5 mail.hospitaldeninos.cl.

Whenever I try to send anything to that domain I just get the following
in my logs:

[...] delay=01:00:57, xdelay=00:01:15, mailer=esmtp, pri=210425,
relay=mail.hospitaldeninos.cl. [], dsn=4.0.0,
stat=Deferred: Operation timed out with mail.hospitaldeninos.cl.

$sendmail -q -v
<[EMAIL PROTECTED]>... Connecting to
nt_sql_server2.hospitaldeninos.cl. via esmtp...
<[EMAIL PROTECTED]>... Connecting to mail.hospitaldeninos.cl. via
<[EMAIL PROTECTED]>... Deferred: Operation timed out with

Now, I've tried so many things. I put

define(`confBIND_OPTS', `WorkAroundBrokenAAAA')dnl

as suggested in some lists into my mc file. I even installed
/usr/ports/mail/sendmail just in case there was a problem with the stock
one as found 5 years ago
I've made my way through all possible mailing-lists on the Internet. I
compiled, recompiled sendmail who knows how many times with different
knobs inside /etc/make.conf. I even ruined my DNS for a few hours trying
to fix... something.

A few days ago, after I ran out of all possible options I could come up
with, I tested my OpenBSD 3.8 box with stock sendmail. The test was
successful right away. I'm able to send all e-mails including those ones
to hospitaldeninos.cl without problems.

So my problem is that the OpenBSD and the FreeBSD box in question sit
behind the same NAT connection. The OpenBSD can send e-mails to
hospitaldeninos.cl but FreeBSD gets deferred and stuck. I guess this
experiment rules out all possibilities that I'm being
blacklisted/probed/checked/whatever. So SMART_HOST isn't my remedy just yet.

I compared (with diff) most of the sendmail's config files (mc, m4, cf)
on both machines. No success in seeing any real difference. They both
run sendmail v8.13.4. I even tried to use my other boxes loaded with
5.3-RELEASE-p29  with sendmail 8.13.1. No success whatsoever. I'm
pulling my hair out.

This is what I get on OpepBSD's log:

[...] delay=00:00:04, xdelay=00:00:04, mailer=esmtp, pri=30905,
relay=nt_sql_server2.hospitaldeninos.cl. [], dsn=2.0.0,
stat=Sent (M2006051714123500106 Message accepted for delivery)

So by comparing the logs, FreeBSD insists on using
mail.hospitaldeninos.cl (MX 5) and fails. On the other hand, OpenBSD
uses nt_sql_server2.hospitaldeninos.cl (MX 4) and succeeds.

Has anyone seen this kind of weirdness? Any ideas on how to fix it? This
is driving me nuts.

Thanks in advance.


Mikhail Goriachev

Telephone: +61 (0)3 62252501
Mobile Phone: +61 (0)4 38255158
Web: http://www.webanoide.org

PGP Key ID: 0x4E148A3B
PGP Key Fingerprint: D96B 7C14 79A5 8824 B99D 9562 F50E 2F5D 4E14 8A3B
freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to