By the way, I've determined our removable IDE disk trays are manufactured
by SNT ( and are part number
SNT-129.  It looks like these are the same ones startech sells.
I've placed my hardware configuration here:

Out of my 4 AMD systems, my test results are now:

 - 1 refuses to die
 - 1 panic'ed and died, after not being able to drop to PIO.  Many
   fsck errors upon reboot.  The console error was "ata0: resetting devices
   .. ad0: DMA limited to UDMA33, non-ATA66 cable or device"
 - 2 dropped to PIO after about 15 hours of tests, and ran fine 
   (but slowly) with PIO

As for the the 2 that dropped to PIO and worked, I rebooted and manually ran

  atacontrol mode 0 UDMA33 UDMA33

and restarted the tests.  No problems in 36 hours so far.  My 4 Intel
systems (which only have a UDMA33 controller on the motherboard)
have also been running 48 hours no problems.

The test I run is...

  dbench 1
  sleep 300
  dbench 2
  sleep 300
  dbench 3
  ... up to about "dbench 80" and then I kill and restart.

With UDMA100, "dbench 10" gave 43 MB/Sec
With UDMA33, "dbench 10" gives 37 MB/Sec

I still plan to:

 - try UDMA100 with the drives directly attached (ie. no removable tray)
 - maybe try a non onboard IDE controller
 - shuffle the disks to see if the problems follow the disks or not

At present, I don't suspect bad media because the error message is
"WRITE command timeout tag=0 serv=0" which doesn't suggest a specific
sector/track etc, and running with UDMA33 instead of UDMA100 makes the problem 
appear to vanish.

This mail sent through

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-questions" in the body of the message

Reply via email to