On 6/13/06, Nikolas Britton <[EMAIL PROTECTED]> wrote:
On 6/13/06, Peter <[EMAIL PROTECTED]> wrote:
> I tried unsuccessfully to build OpenOffice 2.0 on my 5.4 box.  Never
> had enoudh space in /usr...
> I decided to install by package:
> # pkg_add -r openoffice.org
> It tried to install version 1.1.5...
> Anyway, trying to start it gives errors:
> # openoffice.org-1.1.5
> /usr/libexec/ld-elf.so.1: Shared object "libstdc++.so.5" not found,
> required by "javaldx"
> /usr/libexec/ld-elf.so.1: Shared object "libstdc++.so.5" not found,
> required by "soffice.bin"
> Any ideas?

Try KOffice 1.5.1. I've never had a build fail and it now supports ODF
documents... anyways...

1. Remove the openoffice 1.1.5 package.
2. Deinstall linux-sun-jdk14.
3. Deinstall jdk14.
4. Clean up your ports, if you have portupgrade installed type in portsclean -C.

5. cd /usr/ports/java/diablo-jdk15; make install
6. cd /usr/ports/java/jdk15; make install clean
7. cd /usr/ports/java/diablo-jdk15; make deinstall
8.  don't remember if you need to change devel/bison.
9. cd /usr/ports/editors/openoffice.org-2.0; make install clean
10. when build fails (it will) report back to us.

Here's the first problem you will run into:

===>  bison-2.1_2 conflicts with installed package(s):

     They install files into the same place.
     Please remove them first with pkg_delete(1).
*** Error code 1

Stop in /usr/ports/devel/bison2.
*** Error code 1

Stop in /usr/ports/editors/openoffice.org-2.0.

The fix is simple:
# cd ../../devel/bison
# make deinstall
# cd ../bison2
# make install clean
# cd ../../editors/openoffice.org-2.0

BSD Podcasts @:
freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to