> On Saturday,  4 January 2003 at 20:30:52 -0500, Phillip Smith wrote:
> > on 1/4/03 6:50 PM, Stephen Hovey at [EMAIL PROTECTED] wrote:
> >> On Sat, 4 Jan 2003, Phillip Smith wrote:
> >>> Wondering what (if anything) can be done about this?
> >>>
> >>> freedom# tar -xf www.tar
> >>> tar: Skipping to next file header...
> >>> tar: Unknown file type '' for 
> >>> 8˟ܫ[+n_}M2žV28(Uvjuש, 
> extracted 
> >>> as normal file
> >>> tar: Skipping to next file header...
> >>>
> >>> I don't understand what's happened to this archive (and serveral 
> >>> others that represent my entire system backup)? I'm 
> having the same 
> >>> problem with a whole set of archives that I ftp to a 
> remote Windows 
> >>> machine... the ones I stored on my other FreeBSD machine 
> are fine. 
> >>> Did something happen during the transfer?
> >>>
> >>> Also, for each archive, the first few items are extracted 
> properly 
> >>> and then there all this junk... any thought _really_ 
> appreciated. If 
> >>> these are corrupt, I've lost a pile of data.
> >>>
> >>> Many thanks in advance,
> >>
> >> windows ftp defaults to ascii more, not binary, so its 
> adds a \r to 
> >> each \n - you might save your tar files if you upload ascii to get 
> >> them stripped out again.
> >
> > Would it be possible to use a script to achieve the same outcome?
> No, you don't know which \rs have been added.
> > I've tried re-uploading/downlaoding the files in multiple 
> modes, to no 
> > avail.
> It should work with binary transfer.

Tried several times/ways to no avail.

> > Also, I ftp'd these files TO a Windows box FROM my BSD box, so I 
> > believe that the default mode for that would be binary?
> What does ftp say?

FTP is set to binary by default, so I'm quite confused.

> > Are there any other reasons this may have happened? Any way to test?
> I can't think of any other.  It's a traditional problem.  You 
> can test by comparing the size of the archives on each side.

Archives appear to be the same size on both sides.

I'm starting to think that the archives got corrupted somehow? The
archive starts to unpack (I see a few directories and files) then hits a
snag and spews garbage or quits.

Here's a question then... suppose I want to re-mount a drive that had
the data on it, but the drive was one of two drives mirrored with vinum.
I've subsequently changed my drive set-up and now this drive is just
sitting there as a 'hot spare', I haven't newfs'd it or anything... so I
presume the data is still on it. If I were to re-connect the drive, and
re-load vinum, could I access the data? How easy/difficult would this

Thanks again!


To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-questions" in the body of the message

Reply via email to