> -----Original Message-----
> [mailto:[EMAIL PROTECTED]] On Behalf Of 
> Phillip Smith
> Sent: January 9, 2003 10:23 AM
> To: 'Greg 'groggy' Lehey'
> Subject: RE: help! Problems with TAR archives?
> > What does tar t tell you on the FreeBSD side?
> tar: Hmm, this doesn't look like a tar archive.
> tar: Skipping to next file header...
> tar: only read 521 bytes from archive etc.rein.tar
> Also, I tried re-creating the problem. Exact same scenario. 
> Created a new TAR archive, ftp'd from FreeBSD to Window (not 
> specifying a setting), then used 'get' to bring them back to 
> FreeBSD and the archives are fine. So, I'm thinking that the 
> original archives are corrupt...

I've tried a few other scenarios and this is what I've discovered...

- I'm using tar -zcpvf filename.tar.gz targetdir to create the archive
- using any variation of tar -zxpvf gets the messages I've outlined
- same if I gunzip the archive first, then try tar -xpvf

So I tried on some new tar files, only transfering from BSD to BSD and
found that, for some reason, I'm getting the same error (e.g. tar with
zcpvf and ftp/binary from BSD to BSD). Now I'm confused.

So, I repeat the same process without the gzip (tar cpvf and ftp/binary
from BSD to BSD), and presto the archives are fine. I would assume from
this, that I'm doing something wrong with the gzip? Or that gzip is
doing something funny.

Any thoughts?


To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-questions" in the body of the message

Reply via email to