On 09/05/2007, at 8:31 PM, Bram Schoenmakers wrote:

Hi,

I tried to reduce the MTU of a network interface on a remote FreeBSD 6.2
machine.

So that means changing this line in rc.conf:

ifconfig_bge0="inet xxx.xxx.xxx.xxx netmask 255.255.255.128"

to

ifconfig_bge0="inet xxx.xxx.xxx.xxx netmask 255.255.255.128 mtu 1472"

Of course, there's a real IP address set.

Then, I tried to restart the network interface:

/etc/rc.d/netif restart

which went horribly wrong. I lost connection and wasn't able to reconnect. I tried to run this in some 'fallback' script, which automatically should restore the old configuration and restarting the network interface again after 5 minutes. Even if that failed, it should reboot the machine. But somehow the script was aborted, although I ran it in a 'screen' session over SSH. So the last resort was a manual reboot, which started the interface
with MTU 1472 just fine.

Could someone please point out where I made the mistake?

When your network interface went down, you lost the connection, your shell lost the terminal and your script was terminated before it could finish doing what it was supposed to. Possibly you need to use something like "nohup" or "screen" (from ports), or have some other form of terminal available.


_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to