On Nov 7, 2007, at 11:15 AM, Marc Fromm wrote:

I am new to the linux-type OS environment. For about a week now I have
tried to do a task which I first thought would be simple-install a
program like firefox.

I did "sudo pkg_add -r firefox" as explained in chapter 4 of the
handbook and received the message:

pkg_add: package 'firefox-,1' or its older version already

I then tried to uninstall firefox like this:

sudo pkg_delete -d -f firefox-,1

It appeard to uninstall.

I next did "sudo pkg_add -r firefox" again and it did this:

Firefox now does not work at all and if I rerun the pkg_add command it
states firefox- is still installed.

Isn't the latest

I tried to instructions at firefox and they did not work:



There are a couple of things you can try. First thing to note, however, is that Linux instructions for software installation will not, typically, work on FreeBSD systems.

You should verify that the package is actually uninstalled.
# ls /var/db/pkg | grep firefox

You should get nothing back. If you do get something, remove each item with the following command
# pkg_delete <name>

<name> should be each item in the list from the previous command.

Once you've verified it's uninstalled, try the pkg_add command again:
# pkg_add -r firefox

Now, if this doesn't work, try installing from your ports tree. Do this with the following command:
# cd /usr/ports/www/firefox && make install clean

If you're using csh/tcsh as your shell, make sure you type rehash so that your PATH gets re-read for new binaries/etc.

Let me know how this goes!

Eric F Crist
Secure Computing Networks

freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to