On Tue, 2003-02-04 at 22:32, [EMAIL PROTECTED] wrote:
> On  4 Feb, Muhannad Asfour wrote:
> > Hello.  I've recently faced a rather odd issue that I've never seen
> > before.  I bought a new server (specs below), and I loaded it up with
> > FreeBSD 5.0-RELEASE (I know, I know, not for a production environment,
> > but this is a personal server).  Now, whenever I get about 30
> > simultaneous connections, the box just locks hard.  I tested all the
> > hardware components (CPU, Memory, HD, NIC, etc.) and even bought new
> > ones just to make sure and all end up with the same result.  I can never
> > keep a decent uptime (never went past 2 days so far).  As soon as I get
> > a mediocre http load (30 simul. connections), the box just locks hard. 
> > I built a debug kernel, I tried everything imaginable, and I have not
> > found a solution whatsoever.  Everyone seems to be stumped by this.  I
> > tried FreeBSD 4.7-RELEASE, 4.7-STABLE, 5.0-RELEASE and 5.0-CURRENT on
> > this box.  All give me the same result.  I checked everywhere for
> > relevant logs to explain what is occuring, but had no such luck.  This
> > is truly the million dollar question for me right now, because I have no
> > idea why it would lock under such a petty load.  I'm not sure what to do
> > to fix this issue, I've tried many different areas for support and
> > haven't come up with anything as I stated earlier.  I'm not overclocking
> > or anything if that's what you're wondering.  If anyone could assist me
> > in any way shape or form to get this working, I would appreciate it very
> > very much.  Also, if you e-mail back, I'm not subscribed to the lists,
> > so could you please CC it to me.  In the past 4 hours, it has locked
> > hard about 3 times because of a 28-34 connection load.
> > 
> > Machine Specs:
> > Single Pentium IV 2.4 GHz processor
> > ASUS P4S533 motherboard
> > 512MB DDR333 RAM (will be 1GB next week)
> > 120GB Maxtor 7200rpm (ATA133) HDD
> > 40GB Maxtor 7200 rpm (ATA66) HDD
> > Floppy Disk Drive
> > ATI Rage 128 (32 meg) AGP 4x graphics adapter
> > 52x LG CD-ROM drive
> > 3Com 3C905C-TX NIC
> > Currently running FreeBSD 5.0-CURRENT as of Sunday Feb. 2, 13:02:05 EST
> > 2003.
> > 
> > Thank you very much
> > 
> Could you post your dmesg.
> Also do you have hyperthreading enabled?      

No, only Pentium 4 3.06 have Hyperthreading AFAIK.  And if I do have it
(which I am positive I don't), it's not enabled.

Here's the dmesg output:
Copyright (c) 1992-2003 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
FreeBSD 5.0-CURRENT #1: Sun Feb  2 13:02:05 EST 2003
    [EMAIL PROTECTED]:/usr/src/sys/i386/compile/QUBIX
Preloaded elf kernel "/boot/kernel/kernel" at 0xc04b4000.
Preloaded elf module "/boot/kernel/acpi.ko" at 0xc04b40a8.
Timecounter "i8254"  frequency 1193182 Hz
Timecounter "TSC"  frequency 2394012892 Hz
CPU: Intel(R) Pentium(R) 4 CPU 2.40GHz (2394.01-MHz 686-class CPU)
  Origin = "GenuineIntel"  Id = 0xf27  Stepping = 7
real memory  = 536854528 (511 MB)
avail memory = 516059136 (492 MB)
Initializing GEOMetry subsystem
Pentium Pro MTRR support enabled
npx0: <math processor> on motherboard
npx0: INT 16 interface
acpi0: <ASUS   P4S533  > on motherboard
    ACPI-0625: *** Info: GPE Block0 defined as GPE0 to GPE15
Using $PIR table, 10 entries at 0xc00f1b20
acpi0: power button is handled as a fixed feature programming model.
Timecounter "ACPI-fast"  frequency 3579545 Hz
acpi_timer0: <24-bit timer at 3.579545MHz> port 0xe408-0xe40b on acpi0
acpi_cpu0: <CPU> on acpi0
acpi_button0: <Power Button> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
agp0: <SIS Generic host to PCI bridge> mem 0xf4000000-0xf5ffffff at
device 0.0 on pci0
pcib1: <ACPI PCI-PCI bridge> at device 1.0 on pci0
pci1: <ACPI PCI bus> on pcib1
pci1: <display, VGA> at device 0.0 (no driver attached)
isab0: <PCI-ISA bridge> at device 2.0 on pci0
isa0: <ISA bus> on isab0
ohci0: <SiS 5571 USB controller> mem 0xf3000000-0xf3000fff irq 12 at
device 2.2 on pci0
usb0: OHCI version 1.0, legacy support
usb0: <SiS 5571 USB controller> on ohci0
usb0: USB revision 1.0
uhub0: SiS OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 3 ports with 3 removable, self powered
ohci1: <SiS 5571 USB controller> mem 0xf2800000-0xf2800fff irq 9 at
device 2.3 on pci0
usb1: OHCI version 1.0, legacy support
usb1: <SiS 5571 USB controller> on ohci1
usb1: USB revision 1.0
uhub1: SiS OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 3 ports with 3 removable, self powered
atapci0: <SiS 5591 ATA33 controller> port 0xb800-0xb80f at device 2.5 on
ata0: at 0x1f0 irq 14 on atapci0
ata1: at 0x170 irq 15 on atapci0
sis0: <SiS 900 10/100BaseTX> port 0xa000-0xa0ff mem
0xf2000000-0xf2000fff irq 5 at device 3.0 on pci0
sis0: Ethernet address: 00:e0:18:ab:17:b8
miibus0: <MII bus> on sis0
rlphy0: <RTL8201L 10/100 media interface> on miibus0
rlphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
xl0: <3Com 3c905C-TX Fast Etherlink XL> port 0x9800-0x987f mem
0xf1800000-0xf180007f irq 10 at device 9.0 on pci0
xl0: Ethernet address: 00:01:02:84:e3:7e
miibus1: <MII bus> on xl0
xlphy0: <3c905C 10/100 internal PHY> on miibus1
xlphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
fdc0: <Enhanced floppy controller (i82077, NE72065 or clone)> port
0x3f7,0x3f2-0x3f5 irq 6 drq 2 on acpi0
fdc0: FIFO enabled, 8 bytes threshold
fd0: <1440-KB 3.5" drive> on fdc0 drive 0
ppc0 port 0x778-0x77b,0x378-0x37f irq 7 drq 3 on acpi0
ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/16 bytes threshold
plip0: <PLIP network interface> on ppbus0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
sio0 port 0x3f8-0x3ff irq 4 on acpi0
sio0: type 16550A
sio1 port 0x2f8-0x2ff irq 3 on acpi0
sio1: type 16550A
atkbdc0: <Keyboard controller (i8042)> port 0x64,0x60 irq 1 on acpi0
atkbd0: <AT Keyboard> flags 0x1 irq 1 on atkbdc0
kbd0 at atkbd0
pmtimer0 on isa0
orm0: <Option ROMs> at iomem 0xd0000-0xd07ff,0xc0000-0xc7fff on isa0
sc0: <System console> on isa0
sc0: VGA <16 virtual consoles, flags=0x200>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on
Timecounters tick every 10.000 msec
acpi_cpu: throttling enabled, 8 steps (100% to 12.5%), currently 100.0%
ad0: 117246MB <Maxtor 6Y120L0> [238216/16/63] at ata0-master UDMA33
ad1: 38182MB <MAXTOR 4K040H2> [77578/16/63] at ata0-slave UDMA33
acd0: CDROM <HL-DT-ST CD-ROM GCR-8520B> at ata1-master WDMA2
Mounting root from ufs:/dev/ad0s1a
lock order reversal
 1st 0xc2b5d230 process lock (process lock) @
 2nd 0xc2b5bd34 filedesc structure (filedesc structure) @

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-questions" in the body of the message

Reply via email to