Michael A. Smith wrote:
I'm running FreeBSD 4.7-RC on an Athlon system that serves as our office fileserver (it has a Promise IDE RAID card and two mirrored 1-month old 40GB drives). I'm having some filesystem problems that fsck doesn't seem to fix. There is something going wrong with /dev/ar0s1g (my /usr slice).
You don't mention the make/model of the drives.  There are some (for example,
IBM) drives that are known to be troublesome.  Check the list archives for
some of the complaints that have come through here.

If left alone, with little activity, the machine seems to do OK. I can cause it to crash at any time, however, but doing something like running cvsup or trying to upgrade a big port. It crashes and dumps me into single-user mode to "run fsck manually."

I've been running fsck repeatedly. Each time I run it, it finds problems with the /dev/ar0s1g slice. I can answer "Yes" to the recovery questions (or "No" for that matter) and reboot, but I can always crash the system again. I can even run fsck serveral times in a row and it reports problems (different inode numbers) each time.
Hopefully you haven't been running fsck while that partition is mounted?
Make sure to unmount the /usr partition before running fsck or you'll
create problems.

There are a few other problems the system is having (SSH, cups, and nmbd), but I suspect they're related to this disk issue. I've tried updating to 4.7-STABLE, but the filesystem locks up before I can get through it.

Any thoughts (besides re-formatting, which I may do next week)?
In my experience, if you've managed (by whatever means) to badly corrupt
the filesystem, the only solution is to newfs it.  There are some things
(apparently) that fsck can't fix.

Bill Moran
Potential Technologies

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-questions" in the body of the message

Reply via email to