On Wed, Oct 01, 2008 at 07:28:29PM +0300, John Vliouras wrote:
> I wonder if this is the right place to ask a question regarding FreeBsd7
> and the Handbook.
> The problem is my scanner a Canon Lide 60. Running #scanimage -L I get
> "device `genesys:libusb:/dev/usb1:/dev/ugen0' is a Canon Lide 60 flatbed
> scanner" which is right and it shows up with xsane as root (when I am
> lucky to use xsane as root in gnome)
> I cannot find "/etc/devfs.rules" file, it does not exist. I tried to
> make one adding what I was instructed, to no avail. I tried to put
> "[system=5]" etc in the "/etc/defaults/devfs.rules" file, which exists,
> but it did not work either.

A new install doesn't have a devfs.rules file. You must create it.

What I did to get my scanner and other devices working is the following;

- Use pw(8) to create a group named usb, adding my user-id to the group:

     pw groupadd -n usb -m my_user_id

- Write /etc/devfs.rules to give the usb group access:

     add path 'da*' mode 0660 group usb
     add path 'msdosfs/*' mode 0660 group usb
     add path 'uscanner*' mode 0660 group usb
     add path 'usb*' mode 0660 group usb
     add path 'ugen*' mode 0660 group usb

  (The third 'add' line is for the scanner.)

- Activate the ruleset in /etc/rc.conf:


- Now either reboot the machine, or restart devfs using 
  '/etc/rc.d/devfs restart'

- Then plug in the scanner and switch it on. You should see
  /dev/uscanner appear with the right permissions.

For the scanner to work in sane, you might need to edit its
configuration files. You should edit /usr/local/etc/sane.d/dll.conf to
make it load the genesys backend. (just add a line 'genesys' if not
present.) The LiDE 60 is listed in /usr/local/etc/sane.d/genesys.conf,
but if it doesn't work, add a line 'usb /dev/uscanner0' to genesys.conf.

On my FreeBSD page[1] I documented the system configuration that I did
on my machine. You might find it usefull.


[1] http://www.xs4all.nl/~rsmith/freebsd/index.html
R.F.Smith                                   http://www.xs4all.nl/~rsmith/
[plain text _non-HTML_ PGP/GnuPG encrypted/signed email much appreciated]
pgp: 1A2B 477F 9970 BA3C 2914  B7CE 1277 EFB0 C321 A725 (KeyID: C321A725)

Attachment: pgpRWQaMjgnmV.pgp
Description: PGP signature

Reply via email to