On Sunday 01 March 2009 00:41:54 m.borsat...@alice.it wrote:

> I've installed netbeans from ports without error messages. when I started
> the program I got an error like this: "libpthread.so.2 needed by java not
> found". I've verified that there is a libpthread.so.20 in
> /usr/local/lib/pth.

Did you upgrade your machine to 6.x to 7.x recently and not recompile your 
ports? That's the only way I can think of that would "install netbeans 
without error messages". Your java was compiled on 6.x and used 
libpthread.so.2 and libc.so.6 from there.
If you installed diablo-jdk15 on your 7.x system the compat6x port should have 
been installed automatically.
The other case that could explain this, would be that you modified 
ldconfig_paths in /etc/rc.conf and removed /usr/local/lib/compat/pkg.

Either way, if you have:
diablo-jdk-1.5.* in /var/db/pkg, you should do what Dan said and install 
misc/compat6x.
libmap.conf is a bad idea.
-- 
Mel

Problem with today's modular software: they start with the modules
    and never get to the software part.
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "freebsd-questions-unsubscr...@freebsd.org"

Reply via email to