Steven Friedrich <> writes:

> I've been having trouble with X11 ports, so I deleted all my packages
> and tried to install xorg fresh.
> xorg port failed trying to build cairo, cairo failed because it
> couldn't build libdrm, libdrm failed because cairo's headers weren't
> installed.
> So in summary, I can't install cairo because it wants to build libdrm,
> which won't build/install because it wants cairo.
> And I tried to install packages or the X11 distro from the ftp site
> and also from my 7.2 RC-1 media.  I tried setting the Options for
> "any" as well as RELEASE_7_2_0, to no avail.  My system is up and
> running multi-user, so sysinstall failed to install any packages.
> I built cairo with make -k install, so it would brute force past the
> error, and after that I built libdrm and cairo again with portupgrade
> -fr libdrm cairo.

Not only have I not seen or heard of this problem before, I can't see
any direct dependency of either libdrm or cairo on the other.

Lowell Gilbert, embedded/networking software engineer, Boston area
_______________________________________________ mailing list
To unsubscribe, send any mail to ""

Reply via email to