fist something about my sytem:

Vendor: Fujitsu Siemens
Model: Lifebook B2130
CPU: Intel Celeron 400MHz mobile
Chipset: Intel 443MX
RAM: 192M (64M builtin, 128M additional)
HD: 20GB
Network: Intel EtherExpress 100
Modem: Lucent LT Winmodem 56k
PCMCIA: RL5C475 CardBus
OS: FreeBSD 5.0-RELEASE-p4

the problem:

i have two wireless nic's. one lucent-orinoco and one avaya. both
cards should be supported by the wi driver. but if i insert these cards, i
only get "wi0 init failed" (three times) and "wi0 mac read failed" (three
times). here is a short excerpt of the logs:
wi0: timeout in wi_cmd 0x0000; event status 0x8000
wi0: init failed
wi0: init failed
wi0: init failed
wi0: timeout in wi_cmd 0x0021; event status 0x8000
wi0: timeout in wi_cmd 0x0021; event status 0x8000
wi0: mac read failed 5
wi0: mac read failed 5
wi0: mac read failed 5
device_probe_and_attach: wi0 attach failed 5
i searched with google but the only thing i found was the information,
that "init failed" means, that the initialization of the card was not
succesful. also i tried the debug sysctl switches, but it gives no
information about this problem.
i tried a non wireless nic with the same kernel and it works without
problems. card was found and initialized without any errors.

next i tried the wireless cards on a FreeBSD-4.7 system, and the init
process there was succesful.

now i've recompiled my kernel with an OLDCARD config style.

and surprise, the cards are working, without problems.
so i searched the docs, and the source, but there i found nothing about
problems with the wi driver and "NEWCARD".

can anyone point me in the right direction to fix this problem, because i
need the 32-bit cardbus support for other cards.

thanks in advance

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-questions" in the body of the message

Reply via email to