Roland Smith wrote:
> On Wed, Aug 12, 2009 at 03:54:31PM -0400, PJ wrote:
>> Well, I've been looking at the disk(s) and I have found some interesting
>> "shei**e" that doesn't make sense.
>> 1. The fbsd minimal installation that I had set up for recovery of the
>> previous crash does not boot... Now, why in Hades is that? I hadn't
>> touched the disk since last using it to look at the corrupted disk
>> through an usb connection. The current crashed installetion was done
>> afterwards and the only change was in the bios to set the boot disk to
>> the new installation. The installation was finally completed with all
>> the programs working fine... and then BOOM!
>> 2. I tried booting from all the disks on the machine (4 disks) and only
>> the current crashed one booted!... so, it's not the boot sector at
>> all... something is screwy on this machine; either the motherboard is
>> buggered (which I doubt, but not entirely), the disks are finished or
>> theres some kind of gremlin lurking in the confines of the box.
> This sounds more and more like hardware troubles. 
> A few things to check (in order of decreasing likelyness IMHO):
> - Cables to the harddisks: Make sure they are properly connected. A machine of
>   mine suddenly started getting disk read errors after I put in another
>   graphics card. It turned out that the SATA connector to that drive had come
>   partially loose.
> - Powersupply: check the voltages (preferably under load) with a monitoring
>   app like mbmon. If that's not possible, check in the BIOS. A failing
>   powersupply can give weird unreproducable errors. If you have ever heard a
>   popping noise from the machine it could be a short in the powersupply caused
>   by dust. I've seen that fry motherboards.
> - PCI cards: check that they are seated properly. Although in this case I'd
>   say this seems the least likely.
> Roland
I apologize for the lengthy explanation below, but perhaps it will give
some insight on what is see from this end:

Ok, I've had all night to (subliminally) think about all this and
actually, I am tending more toward problems in FreeBSD... (this is not
an apology or a defense of my lack of knowledge or capacities, just a
clarification so you know what kind of a dummy you're dealing with)
First, let me explain that everything that we have been talking about -
the recovery methods, installation, hardware problems, etc. are all
extremely, and I mean extremely, subject to an awful lot of variables.
Therefore, determining what exactly has or is going wrong is almost a
complete impossibility. Let me explain and you will get an idea of what
I mean (and of the difficulties I am facing).
First, I am not an experienced programmer or expert on anything in the
area of computers... however, I am probably one of the most, I would say
not typical but most llikely users of FreeBSD (or any BSD) systems. I
have been usiing FBSD for more than 10 years on and off and not heavily.
I have installed quite a few instances of FBSD. I still have 1 system v.
4.10 as an archive of a couple of older websites I had some 12 years ago
- (too complicated to migrate from postgresql to mysql and to newer
versions because of IP host configurations); another v. 6.4 (or .2 -
whatever) and they work fine. I had v. 7 installed on the machine I am
working on now (on XP as it was multi-boot) and another 7.1 on another
machine. The troubles began when I tried to install flashplayer on the
7.1 machine. At the same time I did manage to arrange my daughters
portable Acer Travelmate 4400 running on AMD Turion 64bit; it was a low
end snail paced horrow with XP so I got rid of that in installed FBSD
64bit and got it work just fine with X Windows, Firefox and even
flashplayer under Linux emulation. This was a few weeks ago... it's
still running fine.
But upgrading to 7.2 and installing flashplayer was pretty much an
impossibility on both of my machines - after extremely time-consuming
(easily several days of long waits for compilation) setups, installs,
reinstallsand portupgrades,  all the programs I need finally came
together in a very satisfying configuration. What I needed - Samba,
apache22, php5.1, mysql, phpMyAdmin, Xorg, java, firefox, flashplayer,
cups, NetBeans and along with a few small proggies like
bash4 and fluxbox for X. Everything seemed to work fine. I ran all the
programs and saw that all the files I had recovered from the crash were
recovered and working. Man, was I ever happy!
I shut down for the night and looked forward to getting bask to normal
development of my current projects.
In the morning, I boot up and WHAM!... the system is f**cked. And so am I.
Now, the problem is that it is imperative to be able to figure out what
exactly is going on.  Well, the problem with that is that I do not seem
to be in a position to do what is required. For one thing, I do not know
how I can save testing output to an external file when I am working on a
temporary shell on the problem machine. Perhaps you could indicate what
I should be doing or where to look for information.
Another problem is rather a strange quirk or I don't know what - The
problems I am having are on two very similar machines: 1 is a MSI 6758
875P NeoFisr motherboard running on a Pentium 3.0ghz CPU; the other is
the identical board with a Pentium 2.4ghz CPU. The strange thing is that
even with identical bios, the bios does not act the same on both
machines. The final install that was so promising was on the 2.4 ghz
machine. Except for being somewhat slower (I find it rather slow
compared to the the 3ghz, but maybe that's normal) it always worked
without problems.
And in checking the disks with fdisk, fsck, and even running that weird
regenerate progam... I wasn't able to come up with anything
significant... that is, the configuration of the disks seemed to be ok,
the boot sector was ok as it was able to boot but the when the system
was being mounted something went wrong... and looking back, I vaguely
recall something about a "soft update" or something like that which
seems to indicate some stumbling block in the software and not hardware.
Now there a a couple of weird symptoms that don't make any sense to me
anyway - I tried booting a minimal installation on the 2.4ghz machine
from a disk that was set up before the crashed disk was installed and
that boot did not work... there was no reason for it to not work... all
it had was a functioning samba and bash4 with cvsup-without-gui and it
worked fine for checking and recovering files from the other disks both
on the machine and through usb.
All that I am seeing is that there is either a problem with the bios
(which I even reinstalled and that changed nothing in the functioning)
or something is going on with the OS.
I must say, it is weird that with FBSD 7.2 things have not been going
well at all...
I now have set up another instance of 7.2 on a different disk on the
2.4ghz machine and I already find something strange... after installing
the minimum configuration, I installed the packages - samba3.3.3,
cvsup-without-gui, and smartmontools. I tried to run smartctl and cvsup
but nothing worked. The path variable was correct but the shell just
would not pick up on it. I had to start the programs from their directories.
That just doesn't make sense.
So, now I am trying to set up 7.2 on this new disk and let's see what
I'm going to run some tests on those disks, including the one that maybe
is defective... I'll post results if possilbe.
_______________________________________________ mailing list
To unsubscribe, send any mail to ""

Reply via email to