On Thu, Aug 13, 2009 at 09:53:06AM -0400, PJ wrote:
> I apologize for the lengthy explanation below, but perhaps it will give
> some insight on what is see from this end:
> Ok, I've had all night to (subliminally) think about all this and
> actually, I am tending more toward problems in FreeBSD... (this is not
> an apology or a defense of my lack of knowledge or capacities, just a
> clarification so you know what kind of a dummy you're dealing with)
> First, let me explain that everything that we have been talking about -
> the recovery methods, installation, hardware problems, etc. are all
> extremely, and I mean extremely, subject to an awful lot of variables.

I don't understand?

I must confess that I find your explanations sometimes a bit vague. You're
sitting in front of the machine with the problems. We (on the mailing list)
see only what you say. It is difficult for me at least to piece together what
exactly happened.

If you are reporting errors, try to be as specific as possible. E.g. don't say
"I updated the machine and it doesn't boot anymore". Start with something like:
"After running freebsd-update with the options blabla" or "after updating the
machine from the 7.2 CD making the following choices...". And then say "I got
stuck in the FreeBSD logo screen", or "I got stuck on a screen showing the
lines 'Default: 0:ad(0,a)/boot/loader' and 'boot:'". That gives us at
least a chance to see what has gone wrong.

I must say that I have never used the method of updating from CD. I tend to
update the system sources with csup(8), and then rebuild the kernel and
applications from source as explained in the Handbook. This hase never failed
me yet.

> Therefore, determining what exactly has or is going wrong is almost a
> complete impossibility. Let me explain and you will get an idea of what
> I mean (and of the difficulties I am facing).
> The troubles began when I tried to install flashplayer on the
> 7.1 machine. 

I guess I missed that? Can't remember.

> At the same time I did manage to arrange my daughters
> portable Acer Travelmate 4400 running on AMD Turion 64bit; it was a low
> end snail paced horrow with XP so I got rid of that in installed FBSD
> 64bit and got it work just fine with X Windows, Firefox and even
> flashplayer under Linux emulation. This was a few weeks ago... it's
> still running fine.

> But upgrading to 7.2 and installing flashplayer was pretty much an
> impossibility on both of my machines - after extremely time-consuming
> (easily several days of long waits for compilation) setups, installs,
> reinstallsand portupgrades,  all the programs I need finally came
> together in a very satisfying configuration. What I needed - Samba,
> apache22, php5.1, mysql, phpMyAdmin, Xorg, java, firefox, flashplayer,
> cups, NetBeans and Openoffice.org along with a few small proggies like
> bash4 and fluxbox for X. Everything seemed to work fine. I ran all the
> programs and saw that all the files I had recovered from the crash were
> recovered and working. Man, was I ever happy!
> I shut down for the night and looked forward to getting bask to normal
> development of my current projects.
> In the morning, I boot up and WHAM!... the system is f**cked. And so am I.

Did you use 'nextboot' by any chance?

> Now, the problem is that it is imperative to be able to figure out what
> exactly is going on.  Well, the problem with that is that I do not seem
> to be in a position to do what is required. 

> For one thing, I do not know how I can save testing output to an external
> file when I am working on a temporary shell on the problem machine. Perhaps
> you could indicate what I should be doing or where to look for information.

Insert a USB thumbdrive and mount it. Copy the files to it, unmount. The
GENERIC kernel on the CD should have all the necessary drivers for this to work.
Assuming that you're logged in as root, and that your USB drive is recognized
as /dev/da0s1:

mkdir /usbdrive
mount_msdosfs -m 644 -M 755 -l -o noatime -o sync /dev/da0s1 /usbdrive
# copy the files you need...
umount /usbdrive

> Another problem is rather a strange quirk or I don't know what - The
> problems I am having are on two very similar machines: 1 is a MSI 6758
> 875P NeoFisr motherboard running on a Pentium 3.0ghz CPU; the other is
> the identical board with a Pentium 2.4ghz CPU. The strange thing is that
> even with identical bios, the bios does not act the same on both
> machines. 

I don't understand what you mean by that? What do you mean by "doesn't act the

> The final install that was so promising was on the 2.4 ghz
> machine. Except for being somewhat slower (I find it rather slow
> compared to the the 3ghz, but maybe that's normal) it always worked
> without problems.

CPU speed is not the only factor, and probably not the dominating factor in
overall performance. The speed of the RAM and especially the harddisk(s) can
have a much larger inpact because they are several orders of magnitude slower
than the CPU.

> And in checking the disks with fdisk, fsck, and even running that weird
> regenerate progam... I wasn't able to come up with anything

Please capture the output from running fdisk and bsdlabel on the problem disk
and post it here. Maybe we can see something that didn't catch your eye.

> significant... that is, the configuration of the disks seemed to be ok,
> the boot sector was ok as it was able to boot but the when the system
> was being mounted something went wrong... and looking back, I vaguely
> recall something about a "soft update" or something like that which
> seems to indicate some stumbling block in the software and not hardware.

Soft updates is a technique employed by the filesystem to ensure that the file
system stays consistent. See ffs(7): 'man 7 ffs'. And "something went wrong"
and "I vaguely recall something about soft update" is not a lot for us to go 

You know that you can use 'dmesg|less' to recall messages that the kernel put
out? Or use 'tail -n 100 /var/log/messages|less'.

> Now there a a couple of weird symptoms that don't make any sense to me
> anyway - I tried booting a minimal installation on the 2.4ghz machine
> from a disk that was set up before the crashed disk was installed and
> that boot did not work... there was no reason for it to not work... 

If it doesn't boot there is a reason for it. But without information as to
what _exactly_ you did to make it boot from that disk, and what happened (as
in did what did you see the different boot screens) nobody can tell you what

> all it had was a functioning samba and bash4 with cvsup-without-gui and it
> worked fine for checking and recovering files from the other disks both on
> the machine and through usb.

You don't need cvsup-without-gui anymore. A new utility written in C called
csup is part of the base system since 6.2, I believe.

> All that I am seeing is that there is either a problem with the bios
> (which I even reinstalled and that changed nothing in the functioning)
> or something is going on with the OS.
> I must say, it is weird that with FBSD 7.2 things have not been going
> well at all...

I don't want to be rude, but you could have made a mistake somewhere. If
you're futzing around with disks and partitions it is quite easy to screw
something up. Even for people with lots of experience it is sometimes a case
of PEBKAC. :-)

> I now have set up another instance of 7.2 on a different disk on the
> 2.4ghz machine and I already find something strange... after installing
> the minimum configuration, I installed the packages - samba3.3.3,
> cvsup-without-gui, and smartmontools. I tried to run smartctl and cvsup
> but nothing worked. The path variable was correct but the shell just
> would not pick up on it. I had to start the programs from their directories.
> That just doesn't make sense.

That is not a mystery. The default FreeBSD shell, tcsh, doesn't pick up new
programs automatically (for historical reasons) After you install new
programs, you have to give the 'rehash' command for tcsh to pick them
up. See 'rehash' in the tcsh manual page, tcsh(1).

R.F.Smith                                   http://www.xs4all.nl/~rsmith/
[plain text _non-HTML_ PGP/GnuPG encrypted/signed email much appreciated]
pgp: 1A2B 477F 9970 BA3C 2914  B7CE 1277 EFB0 C321 A725 (KeyID: C321A725)

Attachment: pgpudfAiOMGM7.pgp
Description: PGP signature

Reply via email to