Joe Marcus Clarke wrote:
On Sat, 2003-08-23 at 20:56, paul beard wrote:

Michelle wrote:

On Saturday, August 23, 2003, at 05:03 PM, paul beard wrote:

Michelle wrote:

That was clear and the start of the jurney. Please update libtool either
using portupgrade or do it by hand as you do before.


I still cannot upgrade libtool. I can run make, but when I run make install I get the following error:
===> Installing for libtool-1.3.5_1
===> Generating temporary packing list
===> Checking if devel/libtool13 already installed
*** Error code 1
Stop in /usr/ports/devel/libtool13
I tried to run make deinstall and received the following error:
===> Deinstalling for devel/libtool13
*** Error code 1
Stop in /usr/ports/devel/libtool13.

what happens if you run make -dl install ?

I get this output:

echo "===> Checking if devel/libtool13 already installed"
===> Checking if devel/libtool13 already installed
already_installed=`/usr/sbin/pkg_info -q -O devel/libtool13 2> /dev/null`; if [ -n "${already_installed}" ]; then for p in ${already_installed}; do prfx=`/usr/sbin/pkg_info -q -p ${p} 2> /dev/null | /usr/bin/head -n 1 | /usr/bin/sed -ne '1s|[EMAIL PROTECTED] ||p'`; if [ "x/usr/local" = "x${prfx}" ]; then df=`/usr/sbin/pkg_info -q -f ${p} 2> /dev/null | /usr/bin/grep -v "^@" | /usr/bin/comm -12 - /usr/ports/devel/libtool13/work/.PLIST.mktmp`; if [ -n "${df}" ]; then found_package=${p}; break; fi; fi; done; fi;
*** Error code 1

Stop in /usr/ports/devel/libtool13.

Well, that's what I have been getting in my recent attempts to use portupgrade or make install. make works just fine in the port's directory, but make install kicks back the same error. The error seems to come from
/usr/sbin/pkg_info -q -O ${portcategorydir}/${portnamedir}

The man page for pkg_info doesn't show a "-O" argument.

Does anyone know what that -O flag is about?

Yes, it's a new option in FreeBSD 4.7's pkg_info.  Install the
sysutils/pkg_install port, and you should be good to go.  If you're
already running FreeBSD 4.7 or higher, you shouldn't be seeing this
problem if your world is in sync with your kernel.

The pkg_install port should be installed automatically if you're running
an affected version of FreeBSD, but due to a bug, it was not.  This bug
is going to be fixed on the next commit to  Until then,
installing pkg_install manually is the thing to do.

One of the problems I had figuring this out for myself was that nothing claimed pkg_info: this command used to return nothing. My first instinct was to reinstall it but I had no idea how to.

[/usr/ports/www/p5-libapreq]# pkg_info -W /usr/local/sbin/pkg_info
/usr/local/sbin/pkg_info was installed by package pkg_install-20030714

-- Paul Beard <> whois -h ha=pb202

Economics, n.:
        Economics is the study of the value and meaning of J. K.
Galbraith ...
                -- Mike Harding, "The Armchair Anarchist's Almanac"

[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to