>>... Has anyone gotten CUPS working using the
>> foomatic-rip/gimp-print method [from]
>>  I have an Epson Stylus C82 at
>> /dev/lpt0.
>> ...
> Looks like I got it.  I installed the printer
> again using a different driver (one that for some
> reason did not show up the first time I tried)
> and it works now.  

I went through a hassle on the C82, and I don't know
that I could reproduce everything I did, but it's
working for me with multiple resolutions, color and
all.  I used the several CUPS ports in the ports
collection.  Some of the gotcha's (are you listening,

I have to run escputil manually whenever I power-cycle
the printer.  escputil  doesn't work over USB on my
4.7 system (and I'm not going to upgrade in the next
few weeks) so I have both USB and parallel connections
to the printer.  (Running raster prints over parallel
soaks up so much of my 2.2 GHz P4 that everything

A  ps  during printing shows about seven stages in
the pipeline.  The last stage is a program called
 usb  which may or may not be a final driver from
CUPS.  Apparently, there is not enough buffering
in the pipeline after the compute stages because
the printer stops every six or eight sweeps while
CPU usage jumps.  I'm tempted to find the source for
USB, open it up, and put some poll()-based double-
buffering in.

If you are using troff or anything based on it,
beware that it may be looking for its fonts in one
place while the CUPS version of ghostscript (espgs)
may have them in another.  The problem is a version
number. I had to symlink
/usr/local/share/ghostscript/7.06 as
/usr/local/share/ghostscript/7.05 .  (No, it's not the
ideal fix, but I was running out of mindspace in which
to hold all of this.  I dutifully recorded it in the
notebook which I cannot find at the moment!)  I
found this problem when I printed a copy of my resume
and realized that it was printing Courier with the
letters separated by proportional spacing, kerned
and all!  Not good.  (And before you bellyache about
troff, it continues to produce the same results from
age to age, I can produce PDF with various programs,
and I don't have to worry that a file from one version
of  Wurd  will print differently on another version,
or mess up the two-column table, or botch indents
from list to list ....)

To print envelopes, you need to use
   -o PageRegion=COM10
     .   This took me a while to find, and a lot of
frustration.  (CUPS people, how about documenting
exactly what each of these options actually means!)

FYI, my printer resolutions (lpoptions -o Resolution=

    default        360sw
    default/draft  720sw
    default/hq     720hq
    default/photo  1440x1440hq

This is still a work in progress, suggestions are
welcome.  But it's working quite well enough for me
at present, and it seems a reasonable range of speed/
quality tradeoffs.

If you have Q's, feel free to send me mail at
(for the present)  [EMAIL PROTECTED] .

                                        Mark Terribile

Do you Yahoo!?
Yahoo! SiteBuilder - Free, easy-to-use web site design software
[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to