Could anybody explain to me what is up with ports? 

I am using FreeBSD 5.x-p2 and I am using ports and am having one hell of a time 
installing things. 

Here's what is happeng. 

I go to install ports and if it needs to get a dependency it goes and fetches it and 
becomes the usual compile process. Except that the dependency might already be 
installed with the exact version required and so most of the time the ports error out 
telling me I need to make deinstall on some dependency then make reinstall on it. 

And don't even get me started on installing Apache. I tried installing mod_php4 but 
before hand installed apache+ssl and so then mod_php4 doesn't even see that apache is 
already installed and then fetches the version it wants thus blowing out the 
apache+ssl and I have to then reinstall that package to get ssl and apache. 

If I do things with /stand/sysinstall it errors out on a dependency if it is already 
installed instead of ignoring the fact that it is already there and errors out. This 
particular behavour started around 4.8 or so. Maybe earlier but I don't seem to recall 
exactly when this started to happen. 

I tried using the portupgrade stuffs but that just seems to make things worse overall. 

Anybody got any hints as to why it seems ports is having these sorts of problems?
_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to