Hi Garance.

Thanks for your answer, I had tried with the IP only and
the name only in the /etc/hosts.lpd and the problem persist,
but when I add the entry in /etc/hosts the printings go fine
no matter what I had in /etc/hosts.lpd (the name or the IP),
so I can assure you that the problem is because LPD don't
resolve the IP to a name via DNS.

>From windows I resolve the IP to as_nte.intranet.telmex.com

C:\>ping -a -n 1

Haciendo ping a as_nte.intranet.telmex.com [] con 32 bytes de datos:

Respuesta desde bytes=32 tiempo=48ms TDV=58

Estadísticas de ping para
    Paquetes: enviados = 4, Recibidos = 4, perdidos = 0 (0% loss),
Tiempos aproximados de recorrido redondo en milisegundos:
    mínimo = 37ms, máximo =  48ms, promedio =  40ms

I think that the solution to my dilemma, is modify the source
code of LPD.

But before this I like to try the "netgroup" option, where can
I begging to read?.


-----Mensaje original-----
De: Garance A Drosihn [mailto:[EMAIL PROTECTED]
Enviado el: Jueves, 30 de Octubre de 2003 08:08 p.m.
Para: Paredes Sánchez Martín A.; [EMAIL PROTECTED]
Asunto: Re: problems with LPD

At 8:45 PM -0700 10/28/03, <[EMAIL PROTECTED]> wrote:
>I have a printer configured in the BSD, is working fine, now
>I need to enable that other systems print in this printer,
>to do this I add 2 lines to the file /etc/hosts.lpd
>but the remote system can't print, so I run lpd with -c flag
>to enable all the connections error via syslog.
>In the file /var/log/lpd-errs I have this message repeated
>Oct 28 20:25:11 bsdsis lpd[10575]: Host name for remote host
>( not known (8)
>why doesn't print, if the ip is in the file hosts.lpd?
>If I run the command "host", it return me 3
>names and one of them is "as_nte.intranet.telmex.com"

You should only need the real hostname in /etc/hosts.lpd.
You do not need to list the real IP address in addition
to the hostname.

To get the mapping between hosts and IP addresses to work,
you would have to put an entry in /etc/hosts:    as_nte.intranet.telmex.com

and then put just the line:


in /etc/hosts.lpd

>Also, I like to enable the printers (all) in this server
>to be accessible to any one in the net 10.

I saw your earlier question on this, and I believe the answer
is that there isn't any good way to do this.  You might be
able to set something up with a netgroup, although that is
not documented very well.

Garance Alistair Drosehn            =   [EMAIL PROTECTED]
Senior Systems Programmer           or  [EMAIL PROTECTED]
Rensselaer Polytechnic Institute    or  [EMAIL PROTECTED]
[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to