On Mon, 10 Nov 2003 20:00:56 +0100, "Karel J. Bosschaart"
> On Mon, Nov 10, 2003 at 10:21:34AM -0700, Robin Schoonover wrote:
> > On Mon, 10 Nov 2003 10:11:30 +0100, "Karel J. Bosschaart"
> > <[EMAIL PROTECTED]> wrote:
> > > On Sun, Nov 09, 2003 at 10:55:38PM +0100, Robin Schoonover wrote:
> > > > 
> > > > On a slightly related note, I've been trying to run some of the
> > > > linux loki demos under FreeBSD.  All work (plus heretic II, which
> > > > has software rendering), except the ones labeled "3d Acceleration".
> > > > The ones labeled "3d Acceleration" tend to crash X.
> > > > 
> > > > One thing I've noticed is when X is started it displays:
> > > > (EE) NVIDIA(0): Failed to load GLX
> This is a serious problem that should be fixed if you want to use
> 3d-acceleration. My log (on 5.1-current) shows
> (II) LoadModule: "glx"
> (II) Loading /usr/X11R6/lib/modules/extensions/libglx.so
> (II) Module glx: vendor="NVIDIA Corporation"
>         compiled for 4.0.2, module version = 1.0.4365
>         Module class: XFree86 Server Extension
>         ABI class: XFree86 Server Extension, version 0.1
> (II) Loading extension GLX
> (II) LoadModule: "nvidia"
> > > > It appears to be finding the GLX stuff, but when it tries to load
> > > > it, it can't.  If it helps any, I have a 'GeForce4 MX 440 with
> > > > AGP8X'.
> Sorry, I don't know why it is not loading :-(. If you have the line
> 'Load "dri"' in your XF86Config, comment it out. It is not needed and
> might cause trouble. I suppose you have the kernel module nvidia.ko
> loaded? 

Yes to both.

> You can test direct rendering by typing 'glxinfo'. It should show 
> (among a lot of other stuff): direct rendering: Yes.

Nope, so naturally glxgears ran poorly. 

> Have a look at http://www.icculus.org . It's the most extensive list
> of Linux games I know off, including useful links.


> Don't forget to check out the nvidia-driver FAQ:
> http://www.soulwax.net/nvidia/faq.shtml

I checked there again...and didn't directly help.

So then I tried running tuxracer, which really wants DRI, but can run
anyway.  No DRI (as we know), but why?  The nvidia stuff is installed,
...isn't it?

Or maybe it was only partially installed (and some of the opengl libs
weren't).  That doesn't make sense... So I reinstalled the nvidia-driver
from ports, and tried running tuxracer again.  Doh!  Crashed X.  Of course,
GLX isn't loaded, so it gets confused, so I'll just have to restart
X....and I get this message:

(II) [GLX]: Initializing GLX extension

Well, that looks promising.  Fire up Descent 3 and....Wow.  Descent 3 is a
lot different from the first one.  So much higher resolution...

Well, thanks for the help.  (although this may be a bad thing..how will I
get -anything- real done??)

Robin Schoonover (aka End)
# The windmills are winning.
[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to