--- Sergey 'DoubleF' Zaharchenko <[EMAIL PROTECTED]> wrote:
> > I wonder whether editing the label and setting both offsets to 0
> > might solve the problem.
> It definitely seems like that, as the actual offset of the partition is
> 0, as dd shows.

Ok, sounds like a plan. Not that I know what I'm doing. Should I use
something like the following command to save my current disklabel?

bsdlabel /dev/ad6s1c > disklabel.ad6s1c.backup

Then do I just edit a copy of that textfile, change the offsets to 0, then
write it back like this?

bsdlabel -R /dev/ad6s1c dislabel.ad6s1c.new

And lastly... your talk about offsets. The man page for bsdlabel describes
using it on the whole disk (ad6) and not a slice or partition. If I run it
on  ad6, I get:

bsdlabel: /dev/ad6: no valid label found

If I run it on the slice ad6s1 I get:

# /dev/ad6s1:
8 partitions:
#        size   offset    fstype   [fsize bsize bps/cpg]
  c: 156344517        0    unused        0     0         # "raw" part, don't
  e: 156344517        0    4.2BSD     2048 16384    89

And there I see the offset of 0 you might be talking about...? Are we
looking at the proper label? Just want to make sure before I mess things up.


[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to