I do not have the FIX-IT CD or another FreeBSD machine.

Is there another fellow FreeBSD'er in the Bay Area, CA that can volunteer to help me troubleshoot the card as described below (e.g. plug in the card and break to debugger to gather info)? I can drive over to your place or you can come over to my house (directions on my homepage).

If it helps, my perspective is that meeting up is totally positve and the only thing left keeping me involved with computing - allow me to explain:

The server was totally idle when the power was cut, and I didn't make any changes while the server was down. I've seen some crazy things working on computers before (I can show you a list, post one to the newsgroup, or if you're curious you can try searching the google groups link on my homepage.) This would by far have to the most stubborn, underhanded, mean, nasty and implausable error I've ever come accross.

I could really use some help getting the filesytem up again; my heart can't take another failure like this, and I'm ready to give up computers (recreationally and professionally) if I can't get this problem fixed. I had just finished recovering from a 2 year reconsolidation of life and data (a 75GXP/Raid-0 failure and data loss occurred while I was studying at UC Berkeley and triggered a very nasty chain of events culminating in this problem.) I can't handle going through another data consolidation; recovering from a recent thyroid removal and a 12-hour neck dissection/removal is a full-time affair, and the 30 some-odd staples in my neck greatly limit my ability to sit at the computer.

Looks like the important thing is for me to make a new friend in the FreeBSD community and a new start on computing, or bid y'all adieu.

Rishi Chopra

Ion-Mihai Tetcu wrote:
On Sun, 08 Feb 2004 21:12:51 -0800
Rishi Chopra <[EMAIL PROTECTED]> wrote:

Here's a summary of my problem so far:

Server was idle (e.g. absolutely no processes running aside from
csh, ttyv0 and ps) when power was cut; server reports a problem mounting /usr partition upon reboot.

I have since tried the following:

(1) Booted into single-user mode and ran 'fsck' - the latest output to the terminal says:

****     FILE SYSTEM MARKED CLEAN     ****
    Last Mounted on /usr
    Phase 1 - check blocks and sizes

After letting the system 'do its thing' for 5+ days, the output did not change.

(2) I tried an 'fsck -p' and got the following message:

/dev/da0s1a: 1128 files, 36058 used, 47059 free (261 frags, 58771 blocks, 0.1% fragmentations)

Do you get the prompt back ? Try fsck -p on / then on /var /tmp and last
/usr. At least you will know what partitions are ok. Better yet I
suggest you boot from the second aka Fixit CD and run fsck from there;
you fsck binary may be broken. Also boot verbose (I don't know if
safe-mode applies to SCSI, but if it does, try that also).

The display has been stuck with that same output for countless hours now.

Do you have disk activity when fsck seems to be stuck ?

Questions I have:

(1) Have I suffered a total loss or is this still some way to revover my filesystem? After suffering a similar loss with a hardware raid-0 failure under win2k, I was assuming the FreeBSD setup would be more durable. I would hate to walk away thinking that a simple power loss could wipe out a freebsd server under nothing more than one terminal login.

Generally this doesn't happen. From my experience, it happens if either
there are problems with the disk access infrastructure (a la timeouts,
etc. on ata) or something bad elsewhere in the kernel.

(2) Why would a simple fsck of the filesystem not work in my case?

If you have the kernel with options DDB

and no disk activity I suggest that you break to debugger hitting
Ctrl+Esc and try to gather some info from there. Note that in case fsck
is actually running this could further damage you fs, but since you
can't do anything else I would say to give it a try.

To summarize:

1. See if you have disk activity when fsck seems to be stuck.

2. Try fsck (-p) first on root, the on tmp, /var, /usr, /home.

3. Esp. if fsck / doesn't go ok try booting verbose with Fixit CD and
run fsck from there.

4. If 1 gets you the same results try putting the disk in another
machine where you have debugging options in the kernel, break to
debugger and gather info from there (esp. if you're running 5.x try
asking on current@ what exactly to look for in the debugger).

[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to