I ran into the same issue.  I found two solutions that worked.  Neither is 
very pretty.

1.  Realizing that I would never install lmtpd, I simply commented out the 
lines in the makefile pertaining to DB3.  The Makefile ended up looking like 

# .if defined(WITH_DB3)
# LIB_DEPENDS+=   db3.3:${PORTSDIR}/databases/db3
# CONFIGURE_ARGS+=        --with-db3=${LOCALBASE}/include/db3 --without-db4
# .else
# CONFIGURE_ARGS+=        --without-db3
# .endif

.if defined(WITH_DB4)
LIB_DEPENDS+=   db4:${PORTSDIR}/databases/db4
CONFIGURE_ARGS+=        --with-db4=${LOCALBASE}/include/db4 --without-db3
CONFIGURE_ARGS+=        --without-db4

Why this sucked: I had to hand-edit the Makefile everytime I cvsuped the ports 

2.  Realizing that DB3 was a 'leaf package' (nothing depended on it), I simply 
ran 'pkg_deinstall db3' at the command line.  You check dependancies by 
running 'pkg_info -a | grep -A 15 db3' at the command line.  Look for a 
"Required By:" line.  As a safeguard, pkg_deinstall won't let you remove db3 
if it's required by other packages.

On Tuesday 04 May 2004 12:24 am, Bob Perry wrote:
> Was unsucessful at upgrading my ports system Saturday due to a
> failure during the port index update.  More specifically, I
> received an error message stating that mail/lmtpd file failed.
> The upgrade process is fairly basic beginning with a backup of
> /var/db/pkg, followed with pkgdb -Fv, cvsup -g -L 2 -z cvsupfile,
> and then portsdb -uU.  The error ocurred during the index update
> and a message followed describing the error stating "Makefile",
> line 47: You cannot use DB3 and DB4 in the same time.
> I located line 47 in the Makefile but didn't recognize any
> error.  I also ran pkg_info to track down the lmtpd package
> but didn't find it.
> Not sure where to go from here.  Any advice would be appreciated.
> Thanks,
> Bob Perry
[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to