On Fri, May 21, 2004 at 02:22:46PM -0400, Bill Moran wrote:
> Gary Kline wrote:
> >     For some months I've had increasing troubles with my 
> >     4.9/4.10 abruptly crashing.  This morning I found my
> >     workhorse server, tao, down and hung up while trying to
> >     fsck /usr.  I cleaned everything thoroughly and then
> >     started xdm.  The grey screen showed, the mouse was frozen;
> >     after 30 seconds, BOOM.  Another crash.  After yet 
> >     another round of fsck's, I tried startx.  To see what 
> >     errs might kill the X11 boot.  No: same blank grey screen,
> >     same frozen mouse,same OS crash.
> >
> >     I tried /stand/sysinstall to reconfigure X.  No luck.
> >     I'm now doing my next stable sup upgrade and am doing
> >     yet another buildworld  && buildkernel.
> >
> >     I doubt this will resolve the X Window snafu, tho.  So:::
> >     what x11/*XFree* ports do I have to fetch/build/install??
> >     ((I'm assuming the reason for the crash was X-related,
> >     but this is only a first-SWAG.) Also, if anybody has had a 
> >     similar problem, please let me know.
> I'm just speculating, but it sounds like it's your window manager
> that's not starting, although X seems to actually be working.

        When I just tried X with startx (as root), I always got
        the defaukolt twm. Here is what in root's .xsession::

        twm &
        xterm &
        xterm &

        I'm using ctwm in my /home/kline acct.  Pretty basic.

> You could easily test this by editing ~/.xinitrc to use twm (a
> very simple wm) instead of what you're currently using.  If startx
> works after that, then you don't need to fix X, you just need to fix
> your wm.

        Hm.  /root had no .xinitrc.  Still, before it made no difference.
        I just created /root/.xinitrc and will try.

> In my experience, big, complex wms like Gnome and KDE tend to have
> trouble off and on.  I've found that deleting everything from /tmp
> will sometimes fix things.  Other times, I've been able to get things
> going again by deleting the .gnome (and other, similar directories)
> from my home directory.  Note that this second one blows away all your
> Gnome settings.

        I'm test gnome and kde3 on my new 5.2 server; it's temp'y 
        offline.  There are lots of GUI-goodies in these wmanagers
        but my bias is to 'keep it simple, sir'.  ctwm along with
        lots of tuning has served for around 7 years... .

        Snce my mouse "X" was frozen, maybe the mouse daemon never
        exec'd.  Could that have crashed the OS?  Another strange
        new fault is that rc.network took a long time to do anything.

        This line:

        May 21 09:55:17 tao /kernel: Doing initial network setup:

        hung more than a minute.  Do you//does anybody have a clue
        re this new problem?

        Anyway, thanks for your data-points.  I'll summarize to
        the list if/when I figure out what's going oon.  I've had
        lots of strange events, but this is a new one......


   Gary Kline     [EMAIL PROTECTED]   www.thought.org     Public service Unix

[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to