This is just a final note about this problem.  I won't say it is
"solved" but at least we have a workaround.

This is from 4.10 release, src/dev/fxp/if_fxp.c, lines 509 et ff.
with the 'offending' code ifdef'd out by me:

         * Determine whether we must use the 503 serial interface.
        fxp_read_eeprom(sc, &data, 6, 1);
        if ((data & FXP_PHY_DEVICE_MASK) != 0 &&
            (data & FXP_PHY_SERIAL_ONLY))
                sc->flags |= FXP_FLAG_SERIAL_MEDIA;
                sc->flags &= ~FXP_FLAG_SERIAL_MEDIA;

         * Create the sysctl tree

When compiled and ran on an adlink motherboard (EBC-2000),
it now correctly IDs and configures the three fxp devices
on the motherboard:

fxp0: <Intel 82559 Pro/100 Ethernet> port 0xd400-0xd43f mem 
0xe7200000-0xe72fffff,0xe7302000-0xe7302fff irq 11 at device 8.0 on pci0
fxp0: Ethernet address 00:30:64:01:86:ff
inphy0: <i82555 10/100 media interface> on miibus0
inphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
fxp1: <Intel 82559 Pro/100 Ethernet> port 0xd800-0xd83f mem 
0xe7000000-0xe70fffff,0xe7301000-0xe7301fff irq 5 at device 9.0 on pci0
fxp1: Ethernet address 00:30:64:01:94:00
inphy1: <i82555 10/100 media interface> on miibus1
inphy1:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
fxp2: <Intel 82559 Pro/100 Ethernet> port 0xdc00-0xdc3f mem 
0xe7100000-0xe71fffff,0xe7300000-0xe7300fff irq 12 at device 10.0 on pci0
fxp2: Ethernet address 00:30:64:01:94:01
inphy2: <i82555 10/100 media interface> on miibus2
inphy2:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto

and I can 'ifconfig fxpN media xyz' between the supported
media types. 

Once this project is shipped, I'll try and track down the
problem's root cause.  This might still be a hardware issue
(the eeprom is being read wrong, or is not reporting capabilities
correctly, or ???).  

Thanks to Simon Barner and others for helping out with the 


At 16:21 28/06/2004. Richard P. Williamson had this to say:
>At 16:52 25/06/2004. Simon Barner had this to say:
>>Richard P. Williamson wrote:
>>Here another thing you could try: I once had a problem with a 3Com NIC
>>not being detected properly when the driver was compiled statically into
>>the kernel.
>>Removing it and using the module instead made it work...
>Nope, still no joy.  However my boot is telling me userland is out of
>sync with the kernel now, so I'm not prepared to say "it didn't work"
>Per the numbers returned by pciconf, this is a 82559 rev 0x8, which
>is in the table of supported devices.  According to the code, however,
>if the device claims to be 10Mb only, then it isn't even handed to the
>miibus code to configure.  I'm still working my way through the code to
>determine if the 10Mb-ness is being reported by the devices directly,
>or if this is the code's interpretation based on other data requested.
>The two additional 82559 rev 0x8s (on the plug-in PCI card)
>are correctly being passed to the miibus, and this is annoying.
>Thanks for your time in this, anyway.
>[EMAIL PROTECTED] mailing list
>To unsubscribe, send any mail to "[EMAIL PROTECTED]"

[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to