I recently shifted to FreeBSD-5.2 from Windows XP because I know there is a 
bluetooh support in these new 5.x versions. I was so glad that FreeBSD have 
improved a lot! However, I have a problem with installing or making the 
bluetooth file transfer work. Here are the details below:

I followed the documentation by Pav on http://www.oook.cz/bsd/bluetooth.html. 
I was able to pair my Nokia 3660 with my FreeBSD-5.2 which has an MSI 
bluetooth dongle. I was able to discover other devices, and execute other 
built-in commands such as hccontrol, l2ping, l2control, sdptool  etc. But, I 
noticed that the the basic file transfer called OBEX was not yet incorporated 
in the FreeBSD-5.2 and that I have to install an openobex or something. I 
have succesfully installed openobex from sourceforge, but it doesn't have the 
"obexapp" command. The i tried installing the "obexapp" from sourceforge too. 
The problem is that I cant install it.

tar -zxvf obexapp-1.2.tar.gz
(extracts two directories openobex-1.0.1/ and obexapp/)

cd openobex-1.0.1
/usr/local/bin/make install

cd obexapp
(no ./configure and NO README!!!)
so i tried, "make" or "/usr/local/bin/make"
when i tried "make":
banao# make
Warning: Object directory not changed from original /usr/home/misoy/EDV/
cc -I/usr/local/include  -I/usr/local/include/openobex -g -Wsystem-headers 
-Werror -Wall -Wno-format-y2k -Wno-uninitialized  -c main.c
cc -I/usr/local/include  -I/usr/local/include/openobex -g -Wsystem-headers 
-Werror -Wall -Wno-format-y2k -Wno-uninitialized  -c client.c
cc -I/usr/local/include  -I/usr/local/include/openobex -g -Wsystem-headers 
-Werror -Wall -Wno-format-y2k -Wno-uninitialized  -c event.c
cc -I/usr/local/include  -I/usr/local/include/openobex -g -Wsystem-headers 
-Werror -Wall -Wno-format-y2k -Wno-uninitialized  -c sdp.c
cc -I/usr/local/include  -I/usr/local/include/openobex -g -Wsystem-headers 
-Werror -Wall -Wno-format-y2k -Wno-uninitialized  -c server.c
server.c: In function `obexapp_server':
server.c:118: error: too many arguments to function `sdp_open_local'
*** Error code 1

Stop in /usr/home/misoy/EDV/Bluetooth/src/obexapp.

using /usr/local/bin/make:
banao# /usr/local/bin/make
Makefile:23: *** missing separator.  Stop.


[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to