I've been using FreeBSD for many years. Not as my main operating
system, though. But anyway several bugs and patches were contributed
and somebody even added my name into the additional contributors list.
That's pleasing but today I tried to install the FreeBSD 11.0 and I'm
upset about this operating system.

First of all I faced an old problem that I reported here a year ago:
Completely new USB flash drive flashed by the
FreeBSD-11.0-RELEASE-i386-mini-memstick.img file kills every Windows
again. If I use the Rufus util to write the img file (using DD mode)
the Windows dies immediately after the flashing. If I use the
Win32DiskImager (suggested by the Handbook) it doesn't reinitialize
the USB storage and Windows dies only if I remove and put that USB
flash drive again or boot Windows when it is connected. Nothing was
done to fix this nasty bug for a year.

Ok, I've used the trick and rebooted Windows manually into the BIOS
setup right after I flashed the USB disk by the Win32DiskImager. The
FreeBSD 11.0 installation has started. I did it on my old computer
with MBR disk schema and installed the FreeBSD on the second MBR slice
(ada0s2). The installation finished. I changed the BIOS boot
configuration back, started to reboot and quickly removed the USB
flash drive (I didn't want to kill Windows again). But suddenly my
computer appeared unbootable. The new MBR code, that was rewritten
without any notation, can't find any OS. I tried to reboot several
times. Why bsdinstall doesn't ask about changing the MBR code? Maybe I
don't want to change it. Or maybe I want to install the BSD boot
manager version of the MBR code (boot0cfg -B).

Ok, I booted from the installation USB drive again and ran 'boot0cfg
-B ada0'. My computer is bootable again, but only for Windows. If I
press F1 the Windows boots properly. If I press F2 or F2 and Enter I
see only hash tags. If I reboot after that I see F2 already selected.
But if I wait (for F2 - FreeBSD) to the selected OS automatic boot I
see the hash tags again. WTF? I've never seen such bugs with boot0 in
any previous FreeBSD version.

I'm upset. Someone else at my place was throwing the FreeBSD 11.0
installation media far away right after the first problem. What is
going on? At least, how to finish the quest?

FreeBSD is losing popularity for Linux these days. I think such a bad
user experience of very basic use cases is one of the main reason for
this loss. Forgive me for saying that, I'm just upset.
freebsd-stable@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-stable-unsubscr...@freebsd.org"

Reply via email to