On Mon, Oct 17, 2016 at 3:39 PM, Rostislav Krasny <rosti....@gmail.com> wrote:
> On Mon, Oct 17, 2016 at 3:31 PM, krad <kra...@gmail.com> wrote:
>> Does this just affect MBR layouts? If possible you might want to consider
>> UEFI booting for both windows and other os's, It's probably safer as you
>> dont need to plays with partitions and bootloaders.
> This is an old computer that doesn't support UEFI booting. In a past I
> tried older FreeBSD versions on it and I don't remember any boot issue
> with them. At least up to 9.X versions.

Ok. I dropped the FreeBSD ada0s2 slice and rewrote the MBR code by
MbrFix util from www.sysint.no/mbrfix
Then I tried to install FreeBSD 11.0 again. Previously I used the
manual partitioning and now I used the guided UFS partitioning. This
time FreeBSD was installed properly without any boot issue. FreeBSD
was booting straight away. After that I ran "boot0cfg -B ada0" and the
boot0 boot manager is working properly again: both F1 for Windows and
F2 for FreeBSD.

It's much better than in my first try. There probably is some bug in
the bsdinstall(8) when the manual partitioning is used instead of the
guided one.
freebsd-stable@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-stable-unsubscr...@freebsd.org"

Reply via email to