On 31.07.2010 23:43, Hans Petter Selasky wrote:
Can you compile the kernel with "options USB_DEBUG". Then set the following
debug variable:

sysctl hw.usb.ural.debug=15

What is printed in dmesg, when you try to activate the wlan0?

--HPS
I compiled kernel with "options USB_DEBUG", set hw.usb.ural.debug to 15, inputed into console "ifconfig wlan0 create wlandev ural0".

There are no messages in dmesg or 1st console. dmesg ends with string "rl0: link state changed to UP"

In "top" process ifconfig uses 100% of CPU core. If you wish I can send you the photo of "top".

After 10 minutes there several messages displays on dmesg:

   Aug  2 01:25:46 lepis kernel: calcru: runtime went backwards from
   1506 usec to 1483 usec for pid 1358 (csh)
   Aug  2 01:25:46 lepis kernel: calcru: runtime went backwards from
   414 usec to 344 usec for pid 1317 (inetd)
   Aug  2 01:25:46 lepis kernel: calcru: runtime went backwards from
   734 usec to 610 usec for pid 1277 (sendmail)
   Aug  2 01:25:46 lepis kernel: calcru: runtime went backwards from
   544 usec to 452 usec for pid 1277 (sendmail)
   Aug  2 01:25:46 lepis kernel: calcru: runtime went backwards from
   537 usec to 446 usec for pid 1273 (sendmail)
   Aug  2 01:25:46 lepis kernel: calcru: runtime went backwards from
   687 usec to 570 usec for pid 1257 (sshd)
   Aug  2 01:25:46 lepis kernel: calcru: runtime went backwards from
   4830 usec to 4629 usec for pid 966 (syslogd)
   Aug  2 01:25:46 lepis kernel: calcru: runtime went backwards from
   304 usec to 253 usec for pid 811 (devd)
   Aug  2 01:25:46 lepis kernel: calcru: runtime went backwards from
   7516 usec to 6244 usec for pid 811 (devd)
   Aug  2 01:25:46 lepis kernel: calcru: runtime went backwards from
   18540 usec to 17888 usec for pid 4 (g_down)
   Aug  2 01:25:46 lepis kernel: calcru: runtime went backwards from
   949398 usec to 793650 usec for pid 1 (init)
   Aug  2 01:25:46 lepis kernel: calcru: runtime went backwards from
   5350 usec to 4664 usec for pid 0 (kernel)


On 7.3-STABLE on the same computer I have the same messages, but all works normally:

   calcru: runtime went backwards from 193 usec to 160 usec for pid 128
   (adjkerntz)
   calcru: runtime went backwards from 24328 usec to 20212 usec for pid
   30 (usbtask-dr)
   calcru: runtime went backwards from 633 usec to 560 usec for pid 24
   (swi6: task queue)
   calcru: runtime went backwards from 5000 usec to 4622 usec for pid 0
   (swapper)



--
? ?????????,
??????? ???????
+7(926) 249-90-25
http://lepisgame.net.ru

_______________________________________________
freebsd-usb@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-usb
To unsubscribe, send any mail to "freebsd-usb-unsubscr...@freebsd.org"

Reply via email to