In message <201108201555.04355.hsela...@c2i.net>, Hans Petter Selasky writes:
>On Friday 19 August 2011 18:01:29 Poul-Henning Kamp wrote:
>>         With this patch I can get a Huawei E173 3G dongle to work.
>>         I'm not sure why I have to teach umodem about it specifically.
>>         It comes up as /dev/cuaU[012] rather than /dev/cuaU0.[012]
>
>Hi,
>
>What happens if you leave out the u3g.c patch?
>
>Could you post dmesg and output from:
>
>usbconfig -d X.Y dump_device_desc dump_curr_config_desc show_ifdrv

Dang, I should have thought of including that.

It's too late now the E173 just passed through my lab for a few
hours and it probably won't be back in the forseeable future.

Without any patches it comes up with the E173_INIT product-id and
da0/cd0 attaches.

The HUAWEI_INIT mode just hangs the device, nothing happens or
attaches afterwards.

With the HUAWEI_INITSCSI it disaspears, then comes back with the E173
product-id, da0/cd0 attaches, but umodem for some reason does not.

The patch makes umodem find it, but as three separate devices,
not as one device with three subdevices.

-- 
Poul-Henning Kamp       | UNIX since Zilog Zeus 3.20
p...@freebsd.org         | TCP/IP since RFC 956
FreeBSD committer       | BSD since 4.3-tahoe    
Never attribute to malice what can adequately be explained by incompetence.
_______________________________________________
freebsd-usb@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-usb
To unsubscribe, send any mail to "freebsd-usb-unsubscr...@freebsd.org"

Reply via email to