Hi Hans!

On 24.10.2011 09:19, Hans Petter Selasky wrote:
> On Monday 24 October 2011 09:07:41 Franz Schwartau wrote:
>> Maybe my "attached" was misleading. The port I attached the QuickPort
>> docking station is capable of high speed in regard of the hardware. But
>> FreeBSD attaches the device to an OHCI instead of an EHCI. Of course I
>> tried different ports and cables.
> 
> Hi,
> 
> High speed mode requires some additional signalling called High Speed chirp. 
> If this fails, FULL speed is the default fallback mode. Does other devices  
> besides from the HUB work in High Speed mode? Have you tried other HUB brands?

There is no extra USB hub (in the sense of an extra device). The
QuickPort is directly connected to the USB ports of the motherboard. I
tried four different ports. At least two of them are capable of high
speed. The Sharkoon RapidCase (External HDD DMI) and an USB memory stick
(Flash Voyager Corsair) are set to high speed:

ugen0.1: <OHCI root HUB ATI> at usbus0, cfg=0 md=HOST spd=FULL (12Mbps)
pwr=SAVE
ugen1.1: <OHCI root HUB ATI> at usbus1, cfg=0 md=HOST spd=FULL (12Mbps)
pwr=SAVE
ugen2.1: <EHCI root HUB ATI> at usbus2, cfg=0 md=HOST spd=HIGH (480Mbps)
pwr=SAVE
ugen3.1: <OHCI root HUB ATI> at usbus3, cfg=0 md=HOST spd=FULL (12Mbps)
pwr=SAVE
ugen4.1: <OHCI root HUB ATI> at usbus4, cfg=0 md=HOST spd=FULL (12Mbps)
pwr=SAVE
ugen5.1: <EHCI root HUB ATI> at usbus5, cfg=0 md=HOST spd=HIGH (480Mbps)
pwr=SAVE
ugen6.1: <OHCI root HUB ATI> at usbus6, cfg=0 md=HOST spd=FULL (12Mbps)
pwr=SAVE
ugen2.2: <Flash Voyager Corsair> at usbus2, cfg=0 md=HOST spd=HIGH
(480Mbps) pwr=ON
ugen2.3: <External HDD DMI> at usbus2, cfg=0 md=HOST spd=HIGH (480Mbps)
pwr=ON
ugen1.2: <product 0x2490 vendor 0x04fa> at usbus1, cfg=0 md=HOST
spd=FULL (12Mbps) pwr=ON

But if I connect the QuickPort it is set to full speed no matter which
port or which cable I'm using... And to repeat it: Other OS set the
QuickPort to high speed with the _same_ hardware setup.

        Best regards
                Franz
_______________________________________________
freebsd-usb@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-usb
To unsubscribe, send any mail to "freebsd-usb-unsubscr...@freebsd.org"

Reply via email to