i recently decided to check how well the wacom tablets are
supported under FreeBSD-x11. This post is mostly a followup to


and tries to give extra information on how to address common problems.

In short, recent webcamd versions implement a linux module
which makes the tablet available as /dev/input/event0
so you don't need any specific usb driver.
In turn, xorg uses the wacom_drv.so module to access
these events and convert them to a suitable format.

I used the webcamd version from Hans' tree

    svn --username anonsvn --password anonsvn \
                checkout svn://svn.turbocat.net/i4b/trunk/ports

which is currently at version , and the inputwacom patches at


The patch applies cleanly; at build time you should leave the
usb support not selected (because uwacom does not compile and
probably it is not necessary, either).
I also left HAL disabled in building inputwacom, following
a comment in the original post.

Before running /usr/local/etc/rc.d/wacom onesetup remember to set

        wacom_porttype="usb" # lowercase, not uppercase)
        wacom_types="stylus eraser"

in /etc/rc.conf and also replace "/dev/event0" with "/dev/input/event0"
in /usr/local/etc/rc.d/wacom so that the correct entries are
created in xorg.conf

The proper sequence of actions is the following:

- connect the tablet to the USB port (I tried a recent Bamboo touch
  and an old Wacom FT-0405 (Volito); both worked).
  The tablet identifies as a USB mouse and a uhid device. The mouse is
  possibly picked up by moused, so you should either kill moused on
  the tablet, or make sure that it is not recognised, or the events
  from the mouse will interfere with those from wacom_drv

- start webcamd (either manually or automatically) . This creates
  /dev/input/event0 which is accessed by wacom_drv

- start the X server. The tablet should be recognised and work
  in absolute coordinates.

  I found that by default the table is way too sensitive to pressure,
  so just approaching the tablet with the pen triggers a button pressure.
  You can set the threshold with the following user command (within X):

        xsetwacom --set stylus threshold 200 # range is 0..2047

  I think you can also set the value from within xorg.conf

Hope this helps...

freebsd-usb@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-usb-unsubscr...@freebsd.org"

Reply via email to