ょぅです。

Masaki Mizutani <[EMAIL PROTECTED]> writes:

> firefoxをportupgradeでバージョンアップ(1.0.7? → 1.5)したところ
>
> (Gecko:1125): GLib-GObject-WARNING **: cannot register existing type 
> `GConfClient'
> (Gecko:1125): GLib-GObject-CRITICAL **: g_object_new: assertion 
> `G_TYPE_IS_OBJECT (object_type)' failed
> (Gecko:1125): GLib-GObject-CRITICAL **: g_object_ref: assertion `G_IS_OBJECT 
> (object)' failed
> Segmentation fault (core dumped)
>
> というメッセージを表示して立ち上がらなくなってしまいました。

Firefox のインストール時に自動的にプラグインを検索して、動かないプラグ
イン(linux 用のものなど)までインストールしてしまうみたいです。

/usr/X11R6/lib/firefox/pluginsで、以下のふたつを残して他を削除してくだ
さい。

libnullplugin.so
libunixprintplugin.so

Firefox が動くのを確認したら linuxpluginwrapper などでお好みのプラグイ
ンをインストールすればいいと思います。

関係なかったらごめんなさい。

-- 
清水 洋 (しみずょぅ)

メールによる返信