On Tue, Nov 01, 2016 at 03:16:12PM +0100, Daniel Tihanyi wrote:
> On Tue, 2016-11-01 at 08:02 -0600, The Doctor wrote:
> > On Tue, Nov 01, 2016 at 09:02:57AM +0000, Matt Churchyard wrote:
> > > 
> > > > 
> > > > I was able to install the Windows 2016 using the GUI method.
> > > > 
> > > > One problem.
> > > > 
> > > > It is assigned an IP but
> > > > 
> > > > the netmask and the default route is not showing up.
> > > > 
> > > > Also??The virtual Windows 2016 box does not see a network 
> > > > interface.
> > > This makes very little sense. You usually specify the netmask and 
> > > default route when you assign Windows an IP address.
> > > And how have you assigned the guest an IP address if it has no 
> > > network interface?
> > > 
> > The taps are allocated an IP address.
> > 
> > I fully concur.
> > 
> > In the install at one point, I declare that the IP address, netmask 
> > and gateway are 'declared' at the 'MB ' BIOS interface.
> > 
> > 
> > > 
> > > > 
> > > > What must I do to convince this box that is it on a switch
> > > On the bhyve host it should be configured just like any other 
> > > bhyve virtual machine. The guest should have a virtio-net device, 
> > > which is linked to a tap interface on the host. That tap interface 
> > > should be bridged with whichever physical network adapter you want 
> > > the guest connected to.
> > > 
> > > However, I think I mentioned in a previous message that Windows 
> > > does not have the virtio-net drivers by default. You need to boot 
> > > the guest with the virtio-net driver ISO attached and install the 
> > > driver. You should see the interface in Device Manager flagged as 
> > > not installed/working.
> > > 
> > 
> > That is correct .
> > 
> > I do have an iso of the MB drivers,
> > 
> > namely a Supermicro??X10DRW-i MB?
> > 
> > and?
> > 
> > from Intel I did obtain the .exe file for the i350GbE drivers.
> > I script a 2 phase installation as follows:
> > 
> > 1)
> > 
> > 
> > /usr/sbin/bhyve -c 2 -m 4G -w -H -s 3,ahci-cd,./.iso/14393.0.160715- 
> > 1616.RS1_RELEASE_SERVER_EVAL_X64FRE_EN-US.ISO -s 4,ahci- 
> > hd,windows2016.img -s 5,virtio-net,tap15 -s 
> > 29,fbuf,tcp=0.0.0.0:5900,w=800,h=600,wait -s 30,xhci,tablet -s 
> > 31,lpc -l com1,stdio -l 
> > bootrom,/usr/local/share/uefi-firmware/BHYVE_UEFI.fd
> > windows2016guest
> > 
> > 2)
> > 
> > 
> > /usr/sbin/bhyve -c 2 -m 4G -w -H -s 
> > 3,ahci-cd,./.iso/null-install.iso -s 4,ahci-hd,windows2016.img -s 
> > 5,virtio-net,tap15 -s 29,fbuf,tcp=0.0.0.0:5900,w=1024,h=768,wait -s 
> > 30,xhci,tablet -s 31,lpc -l com1,/dev/nmdm15A -l 
> > bootrom,/usr/local/share/uefi- firmware/BHYVE_UEFI.fd 
> > windows2016guest &
> > 
> > As I said, I have picked up an ISO from the MB manufacturer
> > 
> > let's call it manufacturer.iso .
> > 
> > Where do I place said iso in the 'phase' of things?
> 
> You use virtio network adapters, you have to install the virtio 
> drivers and NOT the drivers for the physical interface. Then configure 
> the IP Address, gateway, etc. in Windows.

>All right, let me repeat what I am up aginst.

>I do set the IP configuration in the virtual BIOS.

>However when the Win2016 VM boots it sees

>1) the localhost

>2) its assigned IP address

>3) A yellow triangle where the ethernet adaptor is.

I'm not sure what people find so difficult about this - Just treat it like it 
was a real Windows machine

1) Do not assign the guest's IP address on the host
2) Do not set the IP in the guest BIOS (I'm not even sure what you mean by this)

As you have found, the virtio-net network adapter has a yellow triangle in 
Windows, because it is not installed. You need to run bhyve but replace the 
Windows ISO with the virtio-net driver ISO, which you can download off the 
Internet; Then install the network driver through VNC. The guest has a 
"virtio-net" interface which is created by bhyve - This has nothing to do with 
your motherboard and you do not need to install any of the motherboard or 
physical interface drivers in the guest.

Once you have the virtio driver installed, you will have a "Redhat VirtIO" 
network adapter in Windows, and you can assign an IP/Netmask/Gateway to this 
just as you normally would in Windows.

Forget about the Linux machines. They have the virtio-net driver built in, so 
you can just configure eth0 out-of-the-box like normal. If you've configured 
their IP addresses on the bhyve host then that's not really the correct way to 
configure things, even if it doesn't actually break anything; The IP address 
should be configured inside the guest OS.

Matt
_______________________________________________
freebsd-virtualization@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-virtualization
To unsubscribe, send any mail to 
"freebsd-virtualization-unsubscr...@freebsd.org"

Reply via email to