On 2017-01-08 18:01, Allan Jude wrote:
> On 2017-01-08 10:18, Nils wrote:
>> Hello, I'm fighting to get vbox vdi images to run under FreeNAS and
>> don't know what else to try. I've filed and commented on these two bugs:
>> https://github.com/pr1ntf/iohyve/issues/227
>> https://github.com/pr1ntf/iohyve/issues/228
>>
>> ...but I think the problem is not with bhyve itself or with iohyve, but
>> either with grub-bhyve or ZFS.
>> Running installation ISOs etc. works fine, but I need to get the VDIs
>> going.,
>>
>> Any pointers are welcome...
>> Thanks
>> Nils
>> _______________________________________________
>> freebsd-virtualization@freebsd.org mailing list
>> https://lists.freebsd.org/mailman/listinfo/freebsd-virtualization
>> To unsubscribe, send any mail to 
>> "freebsd-virtualization-unsubscr...@freebsd.org"
>>
> How are you converting the .VDI to a raw image? bhyve does not yet
> support the .VDI format, only raw.
>

I've done the conversion to raw with both VBoxManage and qemu-img, same
result.

I'm not sure where to add teh text flag, but I don't think that it's a
problem, as grub should be running in a text console. What bothers me is
that grub at the prompt claims not to recognize the (hd0):

|grub> ls (hd0) Device hd0: No known filesystem detected - Total size
16777216 sectors ... where extracting the MBR and looking at it with
fdisk shows the partitions... |

_______________________________________________
freebsd-virtualization@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-virtualization
To unsubscribe, send any mail to 
"freebsd-virtualization-unsubscr...@freebsd.org"

Reply via email to