On Fri, 26 Jul 2013, Adrian Chadd wrote:

Try just doing ifconfig wlan0 -ht

See if that helps

I finally made it back to the wireless router that was having issues. I found that my NIC has no trouble with the router at work with 40MHz.

However, my router at home is setup for 20MHz. The complete setup is 2.4 GHz band, mixed mode (B and G) and 20 MHz width.

Disabling high throughput stops the firmware assertion and wireless works. I tried -ht, -ht20 and -ht40 each with a reboot for a fresh start and received the same results.

On 25 July 2013 17:10, Sean C. Farley <s...@freebsd.org> wrote:
On Thu, 25 Jul 2013, Adrian Chadd wrote:

Ok, then I have no idea.

There's active work on iwn going on in -HEAD. I suggest updating to
that and then tracking development. No, I won't be backporting
anything to -9 or -8; someone else will have to take charge of that
(and field support queries when things don't work.)

I experimented a bit.  A workaround for me is to set the mode to 11b on
wlan0.  While not the best solution, it hopefully narrows down the issue.  I
will at the code later for some ideas of what changed.

On 25 July 2013 16:38, Sean C. Farley <s...@freebsd.org> wrote:

On Thu, 25 Jul 2013, Adrian Chadd wrote:

Try jsut doing:

ifconfig wlan0 create wlandev iwn0
wpa_supplicant -i wlan0 -c /etc/wpa_supplicant.conf

.. ie, don't do an ifconfig iwn0 up

Same result.  I ran with ifconfig_wlan0="WPA" removed from /etc/rc.conf
wpa_supplicant would start:
ifconfig wlan0 destroy

ifconfig wlan0 create wlandev iwn0
wpa_supplicant -i wlan0 -c /etc/wpa_supplicant.conf

On 25 July 2013 15:25, Sean C. Farley <s...@freebsd.org> wrote:

After upgrading my laptop from 8.4-STABLE to 9-STABLE, I have been
use the wireless NIC.  The indicator light will flash for a moment and
surrender.  The error is always the same and reproducible with
iwn0 up".  The system is 9-STABLE (r253048).  This appears to be the
similar to PR 175053:

iwn0: <Intel Ultimate N WiFi Link 5300> mem 0xf8000000-0xf8001fff irq
device 0.0 on pci4

Card details:
iwn0@pci0:4:0:0:        class=0x028000 card=0x11218086 chip=0x42358086
rev=0x00 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Ultimate N WiFi Link 5300'
    class      = network
    bar   [10] = type Memory, range 64, base 0xf8000000, size 8192,
    cap 01[c8] = powerspec 3  supports D0 D3  current D0
    cap 05[d0] = MSI supports 1 message, 64 bit enabled with 1 message
    cap 10[e0] = PCI-Express 1 endpoint max data 128(128) FLR link
                 speed 2.5(2.5) ASPM L1(L0s/L1)
ecap 0001[100] = AER 1 0 fatal 0 non-fatal 1 corrected
ecap 0003[140] = Serial 1 00216affff985c6e

Error (same each time except for time):
wlan0: link state changed to UP
iwn0: iwn_intr: fatal firmware error
firmware error log:
  error type      = "SYSASSERT" (0x00000005)
  program counter = 0x00003130
  source line     = 0x00000585
  error data      = 0x0000000100000000
  branch link     = 0x0000312A0000312A
  interrupt link  = 0x0000091600000000
  time            = 1611815765
driver status:
  tx ring  0: qid=0  cur=0   queued=0
  tx ring  1: qid=1  cur=0   queued=0
  tx ring  2: qid=2  cur=0   queued=0
  tx ring  3: qid=3  cur=2   queued=0
  tx ring  4: qid=4  cur=67  queued=0
  tx ring  5: qid=5  cur=0   queued=0
  tx ring  6: qid=6  cur=0   queued=0
  tx ring  7: qid=7  cur=0   queued=0
  tx ring  8: qid=8  cur=0   queued=0
  tx ring  9: qid=9  cur=0   queued=0
  tx ring 10: qid=10 cur=0   queued=0
  tx ring 11: qid=11 cur=0   queued=0
  tx ring 12: qid=12 cur=0   queued=0
  tx ring 13: qid=13 cur=0   queued=0
  tx ring 14: qid=14 cur=0   queued=0
  tx ring 15: qid=15 cur=0   queued=0
  tx ring 16: qid=16 cur=0   queued=0
  tx ring 17: qid=17 cur=0   queued=0
  tx ring 18: qid=18 cur=0   queued=0
  tx ring 19: qid=19 cur=0   queued=0
  rx ring: cur=0
wlan0: link state changed to DOWN

vmstat -i:
irq258: iwn0                         973          0

Any ideas on what is broken and how to get it to work?

Please Cc me as I am not on this specific list.

Thank you.

freebsd-wireless@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-wireless-unsubscr...@freebsd.org"

Reply via email to