Le mardi 01 décembre 2009 à 11:14 +0200, Marko Lindqvist a écrit :
> 2009/11/28 Pepeto <pepet...@gmail.com>:
> >
> > If I remember correclty, for 2.1, there were many changes in the
> > capability string between 2.1-beta1 and 2.1.1.
> 
> Between 2.1-beta1 and 2.1.0, you mean. It was against our policy, but
> the most active developer of the time did it anyway. I'd like to have
> beta1 already compatible with actual releases since some distributions
> may package beta release already, and we don't want to shut those
> users out from 2.2 games.
> 
> > Maybe should we use
> > something like +2.2-beta mandatory capability, adding new optional
> > capability for bug fixes and remove them when releasing 2.2.1?
> 
>  If we already have made the hard work of making them optional
> capabilities, why would we want to break compatibility when releasin
> 2.2.0?

As I understand, we would need use an extra non-mandatory capability
then.  Even if 2.2-beta1 is not released yet, the svn branch already
contains this capability, so, in my opinion, it is not changeable.



_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to