Follow-up Comment #8, patch #2062 (project freeciv):

updated version; changes:

* rename playercolormode => plrcolormode so it can easily be found by help
* translate 'no color'
* update strings to use '/help' instead of 'help'
* use fc_strcasecmp to check for 'reset'

> There is still the usage of magic values for
> game.server.playercolormode. 

I'm sorry but here I don't know that you mean (or I did changed it in the
attached patch). 'game.server.playercolormode' is defined as GEN_ENUM and all
texts use now the support string as reference. Only in the code magic numbers
are used. Should they be replaced by macros or should I define a real enum
for this setting?


Reply to this item at:


  Nachricht geschickt von/durch Gna!

Freeciv-dev mailing list

Reply via email to