Follow-up Comment #11, bug #18243 (project freeciv):

To reproduce something like this should work (I have not tested what I have
written here, typos possible)

> mkdir ~/gtk2245
> cd ~/gtk2245
> wget http://ftp.gnome.org/pub/gnome/sources/gtk+/2.24/gtk+-2.24.5.tar.bz2
> tar xjf gtk+-2.24.5.tar.bz2
> cd gtk+-2.24.5
> ./configure --prefix=~/gtk2245/install
> make install
> export LD_LIBRARY_PATH=~/gtk2245/install/lib
> export PKG_CONFIG_PATH=~/gtk2245/install/lib/pkgconfig
> cd ~/freeciv.src
> mkdir gtk2245build
> cd gtk2245build
> ../configure
> make
> ./civ


Similar instructions should work for building gtk+2.22.1 for running current
development version of gtk3-client in case someone has older gtk+ installed.
:-)

    _______________________________________________________

Reply to this item at:

  <http://gna.org/bugs/?18243>

_______________________________________________
  Message sent via/by Gna!
  http://gna.org/


_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to