Update of patch #4051 (project freeciv):
Assigned to: None => cazfi
Follow-up Comment #7:
> Do you mean eliminating diplstate_text() and change its users
> to use the specenum's functions in stead or make
> diplstate_text() wrap?
At this point you are probably more qualified to answer that yourself. Does it
seem likely that diplstate_text() will at some point return strings other than
those directly from specenum? If it does, it's worth keeping the function.
Otherwise change callers to access specenum directly.
> also renames diplrel_between() to diplrel_between_is() and
> diplrel_to_other() to diplrel_to_other_is().
In our naming conventions, "is" for boolean functions is usually placed in the
beginning. is_diplrel_between() and is_diplrel_to_other().
Reply to this item at:
Message sent via/by Gna!
Freeciv-dev mailing list