URL:
  <http://gna.org/patch/?4252>

                 Summary: Use qtchooser to run correct version of moc
                 Project: Freeciv
            Submitted by: cazfi
            Submitted on: Mon 14 Oct 2013 10:33:59 PM EEST
                Category: bootstrap
                Priority: 5 - Normal
                  Status: Ready For Test
                 Privacy: Public
             Assigned to: None
        Originator Email: 
             Open/Closed: Open
         Discussion Lock: Any
         Planned Release: 2.5.0, 2.6.0

    _______________________________________________________

Details:

I now have both qt4 and qt5 development files installed to my development
machine. In this setup default moc is the Qt5 one, causing qt-client (which is
Qt4 program) compilation to fail.

Attached patch makes build to use qtchooser, if available, to run correct moc
version.



    _______________________________________________________

File Attachments:


-------------------------------------------------------
Date: Mon 14 Oct 2013 10:34:00 PM EEST  Name: QtChooser-S2_5.patch  Size: 2kB 
 By: cazfi

<http://gna.org/patch/download.php?file_id=19180>
-------------------------------------------------------
Date: Mon 14 Oct 2013 10:33:59 PM EEST  Name: QtChooser.patch  Size: 2kB   By:
cazfi

<http://gna.org/patch/download.php?file_id=19179>

    _______________________________________________________

Reply to this item at:

  <http://gna.org/patch/?4252>

_______________________________________________
  Message sent via/by Gna!
  http://gna.org/


_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to