Follow-up Comment #3, patch #4988 (project freeciv):

So we get to "ugly hack" space. Can we figure how to make API clean in this
respect, or should we rename RPT_CERTAIN as RPT_CERTAIN_EXCEPT_WHEN_NOT and
RPT_POSSIBLE as RPT_POSSIBLE_EXCEPT_WHEN_UNCERTAIN_NOT_ACCEPTED

Yes, the current RTP_xxx -model is probably unsuitable for AI. It was
originally implemented for the client (IIRC the original bug fixed was marking
of Sun Tzu redundancy - as it affects only units, it seemed to provide no
benefits with no unit_type passed to reqs code)

    _______________________________________________________

Reply to this item at:

  <http://gna.org/patch/?4988>

_______________________________________________
  Message sent via/by Gna!
  http://gna.org/


_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to