Hi Shane Baggs,

> I'm using the FreeDOS 1.0 distribution CD for developers.

That is a bit old compared to Rugxulo's but okay...

> When I push F3 immediately after booting, garbage characters display.

What does F3 do normally?

> When FreeDOS has been running for a while, the command prompt will
> return without the command executing.  Rebooting will "fix" this for a

Indeed a very annoying bug in FreeCOM 0.84 but nobody has yet found
a way to predict WHEN it happens. If you can find a way to make it
happen at a more specific time than "after a while", we could use a
debugger to find out what exactly happens when things break. Note
that only running com/exe/... (external commands) breaks, you can
typically still run internal commands like DIR. Is this the same bug
that you are experiencing?

If you do not need long file name support in internal commands, you
can downgrade to the older FreeCOM 0.82pl3 version of command.com,
it has never shown the bug you describe as far as I remember :-).

You can also use the alternative command shell 4DOS, which became
free softare a while ago. Sure, it differs from command.com a bit.

> I tried eliminating all use of high memory and UMB.  The problem persists.

Did you also try not loading (J)EMM386 but only loading HIMEM(X)...?

> Not loading a memory manager can make the problem take longer to occur.

Okay but it still occurs, not good... And you should loat at least
HIMEM(X) and use DOS=HIGH because otherwise DOS uses much more RAM.

> I tried using Rugxulo's floppy distribution (disk 1) which is based
> on a later kernel -- no difference.

The instability is in FreeCOM 0.84 command.com, not in the kernel.

> The first computer is a tower with an Intel SE440BX2 mainboard, P3/550,
> 256 MB RAM, and an 80GB drive with a 40GB FAT32 partition.
> The second computer is a Compaq Armada 3500 notebook, P2/366,
> 128 MB RAM, 6GB HDD with FAT32.

Thanks for the details.

> The disks were originally formatted with Windows 98 SE.
> They now boot to MetaKern.  The tower passes MEMTEST86.
> There's not a lot on the internet about this, but I can't be the only
> one this has happened to!

You definitely are not the only one. As said, the problem is
finding a method to reproduce it at a moment while a debugger
is pointed at command.com to find out what exactly goes wrong.

You can also have a look at the sources, but people have done
so before so it does not seem to be anything blatantly obvious.

Thanks for reporting :-). Please let us know when you have more
ideas on how we could reproduce and possibly fix it in 0.84 :-)


Open Source Business Conference (OSBC), March 24-25, 2009, San Francisco, CA
-OSBC tackles the biggest issue in open source: Open Sourcing the Enterprise
-Strategies to boost innovation and cut costs with open source participation
-Receive a $600 discount off the registration fee with the source code: SFAD
Freedos-user mailing list

Reply via email to